summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/beautifulsoup/beautifulsoup-4.1.3-r1.ebuild')
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.1.3-r1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.1.3-r1.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.1.3-r1.ebuild
deleted file mode 100644
index 90e842ac4c8b..000000000000
--- a/dev-python/beautifulsoup/beautifulsoup-4.1.3-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3} pypy )
-
-inherit distutils-r1
-
-MY_PN="${PN}4"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="Provides pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
-HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/
- https://pypi.python.org/pypi/beautifulsoup4"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-# new html5 awaits keywording of html5lib in Bug 471002
-IUSE="doc test"
-# pending Bug 471002; html5? ( dev-python/html5lib[$(python_gen_usedep 'python{2_6,2_7}' pypy pypy2_0)] )
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- if use doc; then
- emake -C doc html
- fi
-}
-
-python_test() {
- nosetests -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=doc/build/html/.
- distutils-r1_python_install_all
-}