summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flake8/flake8-3.5.0.ebuild')
-rw-r--r--dev-python/flake8/flake8-3.5.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/flake8/flake8-3.5.0.ebuild b/dev-python/flake8/flake8-3.5.0.ebuild
index 13da912b4ca6..e90b92fd28c0 100644
--- a/dev-python/flake8/flake8-3.5.0.ebuild
+++ b/dev-python/flake8/flake8-3.5.0.ebuild
@@ -23,8 +23,10 @@ RDEPEND="
<dev-python/pyflakes-1.7.0[${PYTHON_USEDEP}]
>=dev-python/pycodestyle-2.0.0[${PYTHON_USEDEP}]
<dev-python/pycodestyle-2.4.0[${PYTHON_USEDEP}]
- virtual/python-enum34[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' 'python2*' pypy )
+ $(python_gen_cond_dep '
+ dev-python/configparser[${PYTHON_USEDEP}]
+ dev-python/enum34[${PYTHON_USEDEP}]
+ ' -2)
"
PDEPEND="
>=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]