summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/manuel/manuel-1.9.0.ebuild')
-rw-r--r--dev-python/manuel/manuel-1.9.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/manuel/manuel-1.9.0.ebuild b/dev-python/manuel/manuel-1.9.0.ebuild
new file mode 100644
index 000000000000..516294c9b32d
--- /dev/null
+++ b/dev-python/manuel/manuel-1.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Manuel lets you build tested documentation"
+HOMEPAGE="https://github.com/benji-york/manuel/ https://pypi.org/project/manuel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Required to run tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+#DOCS=( CHANGES.rst )
+
+#PATCHES=( "${FILESDIR}"/${P}-rm_zope_test.patch )
+
+#python_test() {
+# PYTHONPATH=src/:${PYTHONPATH} esetup.py test
+#}