summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/matplotlib2tikz/matplotlib2tikz-0.6.15.ebuild')
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.6.15.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.15.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.15.ebuild
deleted file mode 100644
index 6aaaf8cd6d9e..000000000000
--- a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.15.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
-HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
-SRC_URI="https://github.com/nschloe/matplotlib2tikz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/ImageHash[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-tex/pgf
- )"
-
-# we have not succeeded in getting the tests to work yet ;-)
-RESTRICT="test"
-
-python_test() {
- local -x MPLBACKEND=Agg
- virtx py.test -v || die "Tests failed with ${EPYTHON}"
-}