summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest1
-rw-r--r--dev-python/pybind11/pybind11-2.13.6.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index 93cdae699900..eba7c6fdd950 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -4,3 +4,4 @@ DIST pybind11-2.13.1.gh.tar.gz 789821 BLAKE2B b1634878a9a772d1200c79a5e7554a16a9
DIST pybind11-2.13.3.gh.tar.gz 793263 BLAKE2B ba295fb0dbbeacd5d2b9fa335cf91c4e4b9daee29c7b994f8878b8078d18a18ee48874a3264f5bff280257cf677339324f7875d2f1bb8b855c6097982a71cdcd SHA512 76629d4ad5b91975bbf3fb05580403915f096a4d91b37d947fdbcb3b44783b3f0c9e5a4e289da222902e6b458e29893521523f41d9eb99da7e4890261be00947
DIST pybind11-2.13.4.gh.tar.gz 793802 BLAKE2B efa1bf0d244cd9692e750524b841a884601c121f631fd721d64f192c49ff6ead4eaa4bb13cace42b98673cfd038583fc3716a298b041efd148e992c07b9ee5c3 SHA512 5938c758da5450be645b366190579aa7943294471a0c639c2aeb9d8e9d201ef4fb4dfd0cb1db91390f74dc59f175f6cf47b0c45c20d45ab9f3eeb1a834886de7
DIST pybind11-2.13.5.gh.tar.gz 794599 BLAKE2B 57bf05040902fc1f85cb4661672426a5c9de701157308e2dd0740f3b7eac878bad0f389b08c2b22b52c94766fa1ae0b0da8aa45353b9cbb95c54afbb0282a786 SHA512 bf9ebfbd8e694fbb421d8bdb5362a207a3782685d48988e77aed98363b2fa302e7384b570b02b117d45d5509b1633b096d4fc1ef16f65e6cc8c888b863c1e2cb
+DIST pybind11-2.13.6.gh.tar.gz 800804 BLAKE2B 1f2efa05727ebbcd8e439b83bacfebb21d26a6f8f719e0a627633abdcae59837936e37e6441196e097e0075c9f922048d4e88146bb627d97ada28c48165bddb7 SHA512 497c25b33b09a9c42f67131ab82e35d689e8ce089dd7639be997305ff9a6d502447b79c824508c455d559e61f0186335b54dd2771d903a7c1621833930622d1a
diff --git a/dev-python/pybind11/pybind11-2.13.6.ebuild b/dev-python/pybind11/pybind11-2.13.6.ebuild
new file mode 100644
index 000000000000..aa9826a57444
--- /dev/null
+++ b/dev-python/pybind11/pybind11-2.13.6.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit cmake distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="
+ https://pybind11.readthedocs.io/en/stable/
+ https://github.com/pybind/pybind11/
+ https://pypi.org/project/pybind11/
+"
+SRC_URI="
+ https://github.com/pybind/pybind11/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-cpp/eigen:3
+"
+BDEPEND="
+ test? (
+ <dev-cpp/catch-3:0
+ >=dev-cpp/catch-2.13.9:0
+ dev-libs/boost
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ cmake_src_prepare
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ local mycmakeargs=(
+ # disable forced lto
+ -DHAS_FLTO=OFF
+ # https://github.com/pybind/pybind11/issues/5087
+ -DPYBIND11_FINDPYTHON=OFF
+ -DPYBIND11_INSTALL=ON
+ -DPYBIND11_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Compilation only does anything for tests
+ use test && cmake_src_compile
+}
+
+python_test() {
+ cmake_build cpptest test_cmake_build
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ cd "${BUILD_DIR}/tests" || die
+ epytest -p rerunfailures --reruns=5 "${S}/tests"
+}
+
+python_install() {
+ distutils-r1_python_install
+ cmake_src_install
+}