summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pykka/pykka-3.0.1.ebuild')
-rw-r--r--dev-python/pykka/pykka-3.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pykka/pykka-3.0.1.ebuild b/dev-python/pykka/pykka-3.0.1.ebuild
new file mode 100644
index 000000000000..1d0432f40a8c
--- /dev/null
+++ b/dev-python/pykka/pykka-3.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python implementation of the actor model"
+HOMEPAGE="
+ https://www.pykka.org/en/latest/
+ https://github.com/jodal/pykka/"
+SRC_URI="
+ https://github.com/jodal/pykka/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_7)"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest