summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyparted/pyparted-3.11.3.ebuild')
-rw-r--r--dev-python/pyparted/pyparted-3.11.3.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/pyparted/pyparted-3.11.3.ebuild b/dev-python/pyparted/pyparted-3.11.3.ebuild
index 53553209b627..a058461368ad 100644
--- a/dev-python/pyparted/pyparted-3.11.3.ebuild
+++ b/dev-python/pyparted/pyparted-3.11.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_6} )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="Python bindings for sys-block/parted"
HOMEPAGE="https://github.com/rhinstaller/pyparted/"
@@ -22,3 +22,8 @@ DEPEND="
virtual/pkgconfig
"
RESTRICT="test"
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}