summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-3.0.2.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/pytest/pytest-3.0.2.ebuild b/dev-python/pytest/pytest-3.0.2.ebuild
index 293c43775aec..c28a9884dc4f 100644
--- a/dev-python/pytest/pytest-3.0.2.ebuild
+++ b/dev-python/pytest/pytest-3.0.2.ebuild
@@ -19,15 +19,8 @@ IUSE="test"
# When bumping, please check setup.py for the proper py version
PY_VER="1.4.29"
-RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
-
-# dev-python/pluggy
-# https://github.com/hpk42/pluggy
-# See https://github.com/pytest-dev/pytest/issues/944
-# for why not now
-
-#pexpect dep based on https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
-DEPEND="${RDEPEND}
+COMMON_DEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
+DEPEND="${COMMON_DEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/hypothesis[${PYTHON_USEDEP}]
@@ -36,6 +29,9 @@ DEPEND="${RDEPEND}
dev-python/requests[${PYTHON_USEDEP}]
)
"
+RDEPEND="${COMMON_DEPEND}
+ !dev-python/logilab-common
+"
python_prepare_all() {
chmod o-w *egg*/* || die