summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qpid-python')
-rw-r--r--dev-python/qpid-python/Manifest1
-rw-r--r--dev-python/qpid-python/metadata.xml8
-rw-r--r--dev-python/qpid-python/qpid-python-0.20.ebuild45
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/qpid-python/Manifest b/dev-python/qpid-python/Manifest
new file mode 100644
index 000000000000..25bce3e6c70d
--- /dev/null
+++ b/dev-python/qpid-python/Manifest
@@ -0,0 +1 @@
+DIST qpid-python-0.20.tar.gz 226543 SHA256 0344ffd3af3c03d77e90b0700111b00c18a65770b826a63dfe75806ec8ff22f8 SHA512 c3cc466c3b1e13443c9ac1e04d8dfab8fbdb4460fcc828b91e9d520cacdfa69589ccd1928d8d0cb4012c4d0a22ae9e6dc2803488863ccc53bb568e97f8251b44 WHIRLPOOL 1e7061e9005bf787e8a04ac078a2ff6927e69f101e99507f93a4c283cd18c561523ca910186f1d14c161468e35ef738f2a1ac8f5da04b329c7cc8cd75309f490
diff --git a/dev-python/qpid-python/metadata.xml b/dev-python/qpid-python/metadata.xml
new file mode 100644
index 000000000000..58ef75bf0e87
--- /dev/null
+++ b/dev-python/qpid-python/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <upstream>
+ <remote-id type="pypi">qpid-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/qpid-python/qpid-python-0.20.ebuild b/dev-python/qpid-python/qpid-python-0.20.ebuild
new file mode 100644
index 000000000000..4c0915cd13d7
--- /dev/null
+++ b/dev-python/qpid-python/qpid-python-0.20.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A high-speed platform independent enterprise messaging system for Apache"
+HOMEPAGE="http://qpid.apache.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE="doc examples"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/epydoc[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && "${PYTHON}" setup.py doc_option
+}
+
+src_test() {
+ # For now rm failing tests requiring making a connection, ? via a running broker
+ # Seems 'we' need figure how to start a broker
+ sed -e 's:def testReconnect:def _testReconnect:' \
+ -e 's:testEstablish:_&:' \
+ -e 's:testOpen:_&:' \
+ -e 's:testReconnectURLs:_&:' \
+ -e 's:testTcpNodelay:_&:' \
+ -e 's:testOpenCloseResourceLeaks:_&:' \
+ -e 's:testReconnect:_&:' \
+ -i qpid/tests/messaging/endpoints.py
+ ./qpid-python-test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( ../"${P}"-python2_7/doc/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}