summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/werkzeug/werkzeug-2.0.2.ebuild')
-rw-r--r--dev-python/werkzeug/werkzeug-2.0.2.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/werkzeug/werkzeug-2.0.2.ebuild b/dev-python/werkzeug/werkzeug-2.0.2.ebuild
deleted file mode 100644
index 2393f1d4daef..000000000000
--- a/dev-python/werkzeug/werkzeug-2.0.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Collection of various utilities for WSGI applications"
-HOMEPAGE="
- https://werkzeug.palletsprojects.com/
- https://pypi.org/project/Werkzeug/
- https://github.com/pallets/werkzeug/"
-SRC_URI="
- https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- test? (
- !hppa? ( !ia64? (
- $(python_gen_cond_dep '
- dev-python/greenlet[${PYTHON_USEDEP}]
- ' 'python*')
- ) )
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-xprocess[${PYTHON_USEDEP}]
- dev-python/watchdog[${PYTHON_USEDEP}]
- !alpha? ( !hppa? ( !ia64? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- ) ) )
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
- if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- "tests/test_serving.py::test_server[https]"
- tests/test_serving.py::test_ssl_dev_cert
- tests/test_serving.py::test_ssl_object
- )
- fi
-
- distutils_install_for_testing --via-venv
-
- # the default portage tempdir is too long for AF_UNIX sockets
- local -x TMPDIR=/tmp
- epytest -p no:httpbin tests
-}