summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/watchdog/watchdog-0.9.0.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/dev-python/watchdog/watchdog-0.9.0.ebuild b/dev-python/watchdog/watchdog-0.9.0.ebuild
index 4dbe580e9f7c..e5d5a062db72 100644
--- a/dev-python/watchdog/watchdog-0.9.0.ebuild
+++ b/dev-python/watchdog/watchdog-0.9.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6} pypy)
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy)
inherit distutils-r1 eutils
@@ -15,27 +15,21 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
IUSE="test"
-RESTRICT="!test? ( test )"
CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
RDEPEND="${CDEPEND}
dev-python/argh[${PYTHON_USEDEP}]
dev-python/pathtools[${PYTHON_USEDEP}]"
DEPEND="${CDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
- )"
+ test? ( >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
src_prepare() {
default
rm tox.ini || die
}
-python_test() {
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}
-
pkg_postinst() {
optfeature "Bash completion" dev-python/argcomplete
}