summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/colorama/Manifest1
-rw-r--r--dev-python/colorama/colorama-0.4.5.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/colorama/Manifest b/dev-python/colorama/Manifest
index a2a495069170..275fcb107dca 100644
--- a/dev-python/colorama/Manifest
+++ b/dev-python/colorama/Manifest
@@ -1 +1,2 @@
DIST colorama-0.4.4.github.tar.gz 109439 BLAKE2B cbf08d4bd26924e269fd8b2ae6f9c7ecec905907acb296ded52b6b9c473c1a3b88945563cf00d4ddbf01c5bbfc4244997da20b47051594ca86a632a33c29fed2 SHA512 35501915b79bfc5fe46a36f83790ecd79c82150d6b73a57cd55fbe6431ea5ed7a86676504af90147eeb3a963ffd16890e0220099df579a66f2d8f1f7494f862e
+DIST colorama-0.4.5.gh.tar.gz 113373 BLAKE2B d7b071b1efa585c26c48f26af7a0df9bff25e3986f2615889fd25c34d785c256ac3c4655375f13e7d1bc6972f7fa64bd48a819d988160ceb75fda356d645876d SHA512 d4d3b2a4c6a0966b5c15a12cd789e4b68e5b632c4d745d93fcff5e250fe10e5d45dd2a8bd25f4399cca31a358aecf99f354aa3e1b74369ae382b51bd6c87644f
diff --git a/dev-python/colorama/colorama-0.4.5.ebuild b/dev-python/colorama/colorama-0.4.5.ebuild
new file mode 100644
index 000000000000..643b99ccd355
--- /dev/null
+++ b/dev-python/colorama/colorama-0.4.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
+HOMEPAGE="
+ https://pypi.org/project/colorama/
+ https://github.com/tartley/colorama/
+"
+SRC_URI="
+ https://github.com/tartley/colorama/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # Some tests require stdout to be a TTY
+ # https://github.com/tartley/colorama/issues/169
+ script -eqc "${EPYTHON} -m pytest -vv -s" /dev/null \
+ || die "tests failed with ${EPYTHON}"
+}