summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtscript/qtscript-4.8.7.ebuild')
-rw-r--r--dev-qt/qtscript/qtscript-4.8.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-qt/qtscript/qtscript-4.8.7.ebuild b/dev-qt/qtscript/qtscript-4.8.7.ebuild
new file mode 100644
index 000000000000..22954160520e
--- /dev/null
+++ b/dev-qt/qtscript/qtscript-4.8.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit qt4-build-multilib
+
+DESCRIPTION="The QtScript module for the Qt toolkit"
+
+if [[ ${QT4_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+IUSE="+jit"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/script"
+
+QCONFIG_ADD="script"
+QCONFIG_DEFINE="QT_SCRIPT"
+
+multilib_src_configure() {
+ local myconf=(
+ $(qt_use jit javascript-jit)
+ -no-xkb -no-fontconfig -no-xrender -no-xrandr -no-xfixes -no-xcursor -no-xinerama
+ -no-xshape -no-sm -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif
+ -no-libpng -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-accessibility -no-fontconfig -no-glib -no-opengl -no-svg
+ -no-gtkstyle
+ )
+ qt4_multilib_src_configure
+}