summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtwebchannel')
-rw-r--r--dev-qt/qtwebchannel/Manifest1
-rw-r--r--dev-qt/qtwebchannel/metadata.xml12
-rw-r--r--dev-qt/qtwebchannel/qtwebchannel-5.4.2.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qtwebchannel/Manifest b/dev-qt/qtwebchannel/Manifest
new file mode 100644
index 000000000000..16a3dd49911c
--- /dev/null
+++ b/dev-qt/qtwebchannel/Manifest
@@ -0,0 +1 @@
+DIST qtwebchannel-opensource-src-5.4.2.tar.xz 84620 SHA256 56e3a75b67cb512b2a1e212590fff43e7b648515cda1d673e44139f896fcc16f SHA512 b197675543e3e247f35147e8570172f7e1bc98755f370a8e7a29849fb810eabf2ea5dc121106b9830210c3ffbb4f6d9388ed75eacdd6946bb4dc9b52c985afc2 WHIRLPOOL 3daf70ebab0c1f7991364831da0d8d51df81a218e1e41beacdb2da047bfba787396eaa187ef49eedd6b5f690b7f72fe06f07c9b5b03f1e8f641ed1aab74da7cd
diff --git a/dev-qt/qtwebchannel/metadata.xml b/dev-qt/qtwebchannel/metadata.xml
new file mode 100644
index 000000000000..ddad9f75dce8
--- /dev/null
+++ b/dev-qt/qtwebchannel/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <use>
+ <flag name="qml">Build QML/QtQuick bindings and imports</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://bugreports.qt.io/</bugs-to>
+ <doc>http://doc.qt.io/</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-qt/qtwebchannel/qtwebchannel-5.4.2.ebuild b/dev-qt/qtwebchannel/qtwebchannel-5.4.2.ebuild
new file mode 100644
index 000000000000..b3c9b854605b
--- /dev/null
+++ b/dev-qt/qtwebchannel/qtwebchannel-5.4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit qt5-build
+
+DESCRIPTION="Qt5 framework module for integrating C++ and QML applications with HTML/JavaScript clients"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+IUSE="qml"
+
+DEPEND="
+ >=dev-qt/qtcore-${PV}:5
+ qml? ( >=dev-qt/qtdeclarative-${PV}:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_mod qml quick src/src.pro
+ qt_use_disable_mod qml qml src/webchannel/webchannel.pro
+
+ qt5-build_src_prepare
+}