summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/arel/arel-4.0.2.ebuild')
-rw-r--r--dev-ruby/arel/arel-4.0.2.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ruby/arel/arel-4.0.2.ebuild b/dev-ruby/arel/arel-4.0.2.ebuild
deleted file mode 100644
index ed0dafe20947..000000000000
--- a/dev-ruby/arel/arel-4.0.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.txt README.markdown"
-
-# Generating the gemspec from metadata causes a crash in jruby
-RUBY_FAKEGEM_GEMSPEC="arel.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Arel is a Relational Algebra for Ruby"
-HOMEPAGE="https://github.com/rails/arel"
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "
- doc? ( >=dev-ruby/hoe-3.3.1 )
- test? (
- >=dev-ruby/hoe-3.3.1
- >=dev-ruby/minitest-5.2:5
- )"
-
-all_ruby_prepare() {
- # Put the proper version number in the gemspec.
- sed -i -e "s/ s.version = \".*\"/ s.version = \"${PV}\"/" arel.gemspec || die
-
- sed -i -e '1igem "minitest"' test/helper.rb || die
-}