summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/http-cookie')
-rw-r--r--dev-ruby/http-cookie/Manifest1
-rw-r--r--dev-ruby/http-cookie/http-cookie-1.0.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/http-cookie/Manifest b/dev-ruby/http-cookie/Manifest
index a6f7aadf52ce..90434a0aa4cc 100644
--- a/dev-ruby/http-cookie/Manifest
+++ b/dev-ruby/http-cookie/Manifest
@@ -1 +1,2 @@
DIST http-cookie-1.0.2.gem 37888 SHA256 bcc1b18b5bc3e9302542c9c7f68f1ac0c3100a65dd2831786172e8676773e233 SHA512 447b7fcfd67f64edbd8420672add7ff04f28358ecd8ef59c3bf861b48378729d02bc1e4396259104651794e011ef0de72c892f28fd658474a1fc315b9b750178 WHIRLPOOL 43b67aa72b113dd736896907409512a1e50c543c38c7c5c36245b6873ec0d7fcd865bac687ff188ddfd259aed1acae2cf740e815a865b162e5a494b00de832da
+DIST http-cookie-1.0.3.gem 38400 SHA256 2f11269d817bc52ab2af2721e89a377660a961078de2a3a55fc696d7897e8c00 SHA512 43ac1218e98dd47ee22e33e72e20bc5b55f65e60aadd417641f8a4221eba88995d418c7738a4c35dfba132e05c0c4b0df2b2bedd56c22e82c062d1f03de0052f WHIRLPOOL 39b2a7bdea354345526373cc1dbb4a33ef419c9a62075f89e80ad7e926b0bb58564ebd2325b5c7d39a2dc3255aef0c6a53d08745fa563a34b7bab334e5d08cc5
diff --git a/dev-ruby/http-cookie/http-cookie-1.0.3.ebuild b/dev-ruby/http-cookie/http-cookie-1.0.3.ebuild
new file mode 100644
index 000000000000..e51aaf8cb142
--- /dev/null
+++ b/dev-ruby/http-cookie/http-cookie-1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library to handle HTTP cookies"
+HOMEPAGE="https://github.com/sparklemotion/http-cookie"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/domain_name-0.5:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/d" -e "/bundler/d" Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_http_cookie.rb || die
+ ${RUBY} -Ilib test/test_http_cookie_jar.rb || die
+}