summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rdtool')
-rw-r--r--dev-ruby/rdtool/Manifest1
-rw-r--r--dev-ruby/rdtool/files/50rdtool-gentoo.el5
-rw-r--r--dev-ruby/rdtool/metadata.xml8
-rw-r--r--dev-ruby/rdtool/rdtool-0.6.38-r1.ebuild40
-rw-r--r--dev-ruby/rdtool/rdtool-0.6.38-r2.ebuild40
5 files changed, 94 insertions, 0 deletions
diff --git a/dev-ruby/rdtool/Manifest b/dev-ruby/rdtool/Manifest
new file mode 100644
index 000000000000..2327cf4cb613
--- /dev/null
+++ b/dev-ruby/rdtool/Manifest
@@ -0,0 +1 @@
+DIST rdtool-0.6.38.gem 115712 SHA256 d9d32e215c1958847001ca5940ad42aa8bcbdf984436f1235b9dbd300e4c74bc SHA512 958e9066a8b3610eb1a78069e615c5bd672aa56b3b45669604b35cd094bb8ddc549d8f373d1ee53864c27a0aa7ee038101b3256c56b3b8ffe618f75a1a939bcd WHIRLPOOL 2f066ce8d5dc91059ef74f5ec8f65aa2234afe3b615690e316f2ec8522df4b6aaafae0f041a0f3110be5b2ee77c0ff9ae0a703613ca2f45ab0ad324c0dac70da
diff --git a/dev-ruby/rdtool/files/50rdtool-gentoo.el b/dev-ruby/rdtool/files/50rdtool-gentoo.el
new file mode 100644
index 000000000000..cce968bacb70
--- /dev/null
+++ b/dev-ruby/rdtool/files/50rdtool-gentoo.el
@@ -0,0 +1,5 @@
+
+;; site-lisp configuration file for rdtool
+
+(autoload 'rd-mode "rd-mode" "major mode for ruby document formatter RD" t)
+(add-to-list 'auto-mode-alist '("\\.rd$" . rd-mode))
diff --git a/dev-ruby/rdtool/metadata.xml b/dev-ruby/rdtool/metadata.xml
new file mode 100644
index 000000000000..1a3dd95bd5b3
--- /dev/null
+++ b/dev-ruby/rdtool/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">uwabami/rdtool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rdtool/rdtool-0.6.38-r1.ebuild b/dev-ruby/rdtool/rdtool-0.6.38-r1.ebuild
new file mode 100644
index 000000000000..fb4f3637ad84
--- /dev/null
+++ b/dev-ruby/rdtool/rdtool-0.6.38-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.*"
+
+inherit elisp-common ruby-fakegem
+
+DESCRIPTION="A multipurpose documentation format for Ruby"
+HOMEPAGE="https://github.com/uwabami/rdtool"
+
+LICENSE="Ruby GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="emacs"
+
+RDEPEND="${RDEPEND} emacs? ( virtual/emacs )"
+
+SITEFILE=50${PN}-gentoo.el
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use emacs ; then
+ elisp-install ${PN} utils/rd-mode.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-ruby/rdtool/rdtool-0.6.38-r2.ebuild b/dev-ruby/rdtool/rdtool-0.6.38-r2.ebuild
new file mode 100644
index 000000000000..9a4bbdf37d2d
--- /dev/null
+++ b/dev-ruby/rdtool/rdtool-0.6.38-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.*"
+
+inherit elisp-common ruby-fakegem
+
+DESCRIPTION="A multipurpose documentation format for Ruby"
+HOMEPAGE="https://github.com/uwabami/rdtool"
+
+LICENSE="Ruby GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs"
+
+RDEPEND="${RDEPEND} emacs? ( virtual/emacs )"
+
+SITEFILE=50${PN}-gentoo.el
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use emacs ; then
+ elisp-install ${PN} utils/rd-mode.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}