summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec-pending_for')
-rw-r--r--dev-ruby/rspec-pending_for/Manifest1
-rw-r--r--dev-ruby/rspec-pending_for/metadata.xml11
-rw-r--r--dev-ruby/rspec-pending_for/rspec-pending_for-0.1.16.ebuild31
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/rspec-pending_for/Manifest b/dev-ruby/rspec-pending_for/Manifest
new file mode 100644
index 000000000000..2bac2e90cb2c
--- /dev/null
+++ b/dev-ruby/rspec-pending_for/Manifest
@@ -0,0 +1 @@
+DIST rspec-pending_for-0.1.16.tar.gz 12841 BLAKE2B fb95f7e21e681454252e6dd625c7a7766ee5853ec60f3280c25e591d91a6163dd307ed8583d6e966cca9f1eeac3e3d8543a539f557abaaf41ae424dc8d91d68a SHA512 4d87c82814a2b8f51f79d1c22030870dce98b846add8cab8897d211129ab2116dd28fffe4999e42c35f70393d90448b11067be424af28594600c7dd461de2e80
diff --git a/dev-ruby/rspec-pending_for/metadata.xml b/dev-ruby/rspec-pending_for/metadata.xml
new file mode 100644
index 000000000000..b04340acafd3
--- /dev/null
+++ b/dev-ruby/rspec-pending_for/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pboling/rspec-pending_for</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rspec-pending_for/rspec-pending_for-0.1.16.ebuild b/dev-ruby/rspec-pending_for/rspec-pending_for-0.1.16.ebuild
new file mode 100644
index 000000000000..3270a09848cf
--- /dev/null
+++ b/dev-ruby/rspec-pending_for/rspec-pending_for-0.1.16.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="rspec-pending_for.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mark specs pending or skipped for specific Ruby engine / version combinations"
+HOMEPAGE="https://github.com/pboling/rspec-pending_for"
+SRC_URI="https://github.com/pboling/rspec-pending_for/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/rspec-core
+ dev-ruby/ruby_engine:2
+ dev-ruby/ruby_version:1
+"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/ s:^:#:' spec/spec_helper.rb || die
+}