summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/min-cscope')
-rw-r--r--dev-util/min-cscope/Manifest1
-rw-r--r--dev-util/min-cscope/metadata.xml10
-rw-r--r--dev-util/min-cscope/min-cscope-16.1.0.ebuild29
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/min-cscope/Manifest b/dev-util/min-cscope/Manifest
new file mode 100644
index 000000000000..5c582841ab97
--- /dev/null
+++ b/dev-util/min-cscope/Manifest
@@ -0,0 +1 @@
+DIST min-cscope-16.1.0.tar.gz 382326 SHA256 2d316736d468205abac3343aa9f5795228a6846c86d8d86484ca04f490b6c74b SHA512 434d6333758dbf72c320e08b3b705bbff6c67de8a1380295fe5971af1a2c4659dd3201c726fd318d7715b90f8a693a76599a8659ac45c76568e5a29a399a9c0a WHIRLPOOL a52e4a78579b2f40b3c61e43c53c2c671cdfe0e2b8a3e20c1c3dc5a553ae79768dd273aca1659ccbeb81eccd595484ae0dd1e7d546ec727e0975ea7b0228e730
diff --git a/dev-util/min-cscope/metadata.xml b/dev-util/min-cscope/metadata.xml
new file mode 100644
index 000000000000..35840fce9f6b
--- /dev/null
+++ b/dev-util/min-cscope/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">kscope</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/min-cscope/min-cscope-16.1.0.ebuild b/dev-util/min-cscope/min-cscope-16.1.0.ebuild
new file mode 100644
index 000000000000..075d2ae1486c
--- /dev/null
+++ b/dev-util/min-cscope/min-cscope-16.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Interactively examine a C program"
+HOMEPAGE="http://sourceforge.net/projects/kscope/"
+SRC_URI="mirror://sourceforge/kscope/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+S=${WORKDIR}/${PN}
+
+DOCS="AUTHORS README* TODO"
+
+src_prepare() {
+ echo 'INSTALL(TARGETS min-cscope RUNTIME DESTINATION bin)' \
+ >> src/CMakeLists.txt
+}
+
+src_configure() {
+ append-flags -I"${S}/sort"
+ cmake-utils_src_configure
+}