summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/setconf')
-rw-r--r--dev-util/setconf/Manifest2
-rw-r--r--dev-util/setconf/metadata.xml10
-rw-r--r--dev-util/setconf/setconf-0.6.6.ebuild41
-rw-r--r--dev-util/setconf/setconf-0.6.7.ebuild41
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-util/setconf/Manifest b/dev-util/setconf/Manifest
new file mode 100644
index 000000000000..224e94af4d84
--- /dev/null
+++ b/dev-util/setconf/Manifest
@@ -0,0 +1,2 @@
+DIST setconf-0.6.6.tar.xz 12620 SHA256 1554877f771fd3e509df5fd75c452460fd4ed78d2b23a4cd97710d5cb9831e4f SHA512 28f62b4dbc5883763cd11480ca059dd8ba120d6dfd964bbf1746ec5cb23fb0f0fd949249f77673d150cb6abd0039ff6f34d79ad744f8abcc765e0af37fbb85ff WHIRLPOOL 95fcf26aba2e11c7b5d3a25adb7e813930ac3409b6dc51afdf189ae22025cc6bb5fdc47907c8705d09db34c1cc92036eb59572ffe5baf5955efebac6fbc74e31
+DIST setconf-0.6.7.tar.xz 12700 SHA256 dcc38c2864c4a6d76d161a7aa34eb425f45ee4e7e76ad95050988b437750bb4f SHA512 8b247de9f7ac06f77e6251e95c045886cde5b6ca21b0152cb6fdc1456381aacd9051d5221c9fc8149608555e14f85ee2b51acbe65f78d129b1c8b732e093236d WHIRLPOOL de34abb2cbf49827f4b2a9845c85fdaec76afaeb9858458358e2f82adfcea0f24c4025147707ebfe8be23e2b433334078ad6a7a9de40c60c7ebeb84eb08f2bb2
diff --git a/dev-util/setconf/metadata.xml b/dev-util/setconf/metadata.xml
new file mode 100644
index 000000000000..67dfac8ca4f4
--- /dev/null
+++ b/dev-util/setconf/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <herd>shell-tools</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/setconf/setconf-0.6.6.ebuild b/dev-util/setconf/setconf-0.6.6.ebuild
new file mode 100644
index 000000000000..878b1af8cdd5
--- /dev/null
+++ b/dev-util/setconf/setconf-0.6.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+inherit python-single-r1
+
+DESCRIPTION="A small python based utility that can be used to change configuration files"
+HOMEPAGE="http://setconf.roboticoverlords.org/"
+SRC_URI="http://${PN}.roboticoverlords.org/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=${PYTHON_DEPS}
+
+# "REQUIRED_USE is needed to have a (un-)nice error when someone disabled all of python3" -mgorny
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unpack ./${PN}.1.gz
+}
+
+src_prepare() {
+ python_fix_shebang ${PN}.py #462326
+}
+
+src_install() {
+ dobin ${PN}.py
+ ln -s ${PN}.py "${ED}"/usr/bin/${PN}
+ doman ${PN}.1
+}
diff --git a/dev-util/setconf/setconf-0.6.7.ebuild b/dev-util/setconf/setconf-0.6.7.ebuild
new file mode 100644
index 000000000000..350e359c928c
--- /dev/null
+++ b/dev-util/setconf/setconf-0.6.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+inherit python-single-r1
+
+DESCRIPTION="A small python based utility used to change configuration files"
+HOMEPAGE="http://setconf.roboticoverlords.org/"
+SRC_URI="http://${PN}.roboticoverlords.org/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=${PYTHON_DEPS}
+
+# "REQUIRED_USE is needed to have a (un-)nice error when someone disabled all of python3" -mgorny
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unpack ./${PN}.1.gz
+}
+
+src_prepare() {
+ python_fix_shebang ${PN}.py #462326
+}
+
+src_install() {
+ python_doscript ${PN}.py
+ dosym ${PN}.py /usr/bin/${PN}
+ doman ${PN}.1
+}