summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/unifdef/unifdef-2.10.ebuild')
-rw-r--r--dev-util/unifdef/unifdef-2.10.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-util/unifdef/unifdef-2.10.ebuild b/dev-util/unifdef/unifdef-2.10.ebuild
index 038a1285cef0..7cafc8e46a09 100644
--- a/dev-util/unifdef/unifdef-2.10.ebuild
+++ b/dev-util/unifdef/unifdef-2.10.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
+
inherit toolchain-funcs
-DESCRIPTION="remove #ifdef'ed lines from a file while otherwise leaving the file alone"
-HOMEPAGE="http://dotat.at/prog/unifdef/"
-SRC_URI="http://dotat.at/prog/unifdef/${P}.tar.gz"
+DESCRIPTION="Remove #ifdef'ed lines from a file while otherwise leaving the file alone"
+HOMEPAGE="https://dotat.at/prog/unifdef/"
+SRC_URI="https://dotat.at/prog/unifdef/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -17,4 +18,5 @@ DOCS=( README )
src_prepare() {
sed -i '/^prefix/s:=.*:=/usr:' Makefile || die
tc-export CC
+ default
}