summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/fdk-aac/fdk-aac-0.1.3.ebuild')
-rw-r--r--media-libs/fdk-aac/fdk-aac-0.1.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/fdk-aac/fdk-aac-0.1.3.ebuild b/media-libs/fdk-aac/fdk-aac-0.1.3.ebuild
new file mode 100644
index 000000000000..b5f5006fd9be
--- /dev/null
+++ b/media-libs/fdk-aac/fdk-aac-0.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+ AUTOTOOLS_AUTORECONF=yes
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Fraunhofer AAC codec library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="FraunhoferFDK"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || \
+KEYWORDS="amd64 arm ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x64-macos"
+IUSE="static-libs examples"
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+src_configure() {
+ local myeconfargs=(
+ "$(use_enable examples example)"
+ )
+ autotools-multilib_src_configure
+}