summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libpagemaker/libpagemaker-0.0.3.ebuild')
-rw-r--r--media-libs/libpagemaker/libpagemaker-0.0.3.ebuild32
1 files changed, 18 insertions, 14 deletions
diff --git a/media-libs/libpagemaker/libpagemaker-0.0.3.ebuild b/media-libs/libpagemaker/libpagemaker-0.0.3.ebuild
index 7e2a3af1a397..faf582e328ce 100644
--- a/media-libs/libpagemaker/libpagemaker-0.0.3.ebuild
+++ b/media-libs/libpagemaker/libpagemaker-0.0.3.ebuild
@@ -2,36 +2,40 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils
+EGIT_REPO_URI="git://gerrit.libreoffice.org/${PN}.git"
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
DESCRIPTION="C++ Library that parses the file format of Aldus/Adobe PageMaker documents."
-HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libpagemaker"
-SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/${PN}"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
LICENSE="MPL-2.0"
SLOT="0"
+
+[[ ${PV} == 9999 ]] || \
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug doc tools static-libs"
+IUSE="debug doc tools"
RDEPEND="
dev-libs/librevenge
- "
+"
DEPEND="${RDEPEND}
>=dev-libs/boost-1.47
virtual/pkgconfig
doc? ( app-doc/doxygen )
"
+src_prepare() {
+ eapply_user
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
src_configure() {
- local myeconfargs=(
- --docdir="${EPREFIX}/usr/share/doc/${PF}"
- --disable-werror
- $(use_enable tools)
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-werror \
+ $(use_enable tools) \
$(use_with doc docs)
- )
- autotools-utils_src_configure
}