summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opencollada/files/opencollada-1.2.2-no-undefined.patch')
-rw-r--r--media-libs/opencollada/files/opencollada-1.2.2-no-undefined.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/opencollada/files/opencollada-1.2.2-no-undefined.patch b/media-libs/opencollada/files/opencollada-1.2.2-no-undefined.patch
new file mode 100644
index 000000000000..e3cbf0dbead9
--- /dev/null
+++ b/media-libs/opencollada/files/opencollada-1.2.2-no-undefined.patch
@@ -0,0 +1,35 @@
+Source: https://build.opensuse.org/package/show/graphics/openCOLLADA
+
+Index: OpenCOLLADA-69b844dc9eea0a014326149c259e7810ecec4c8c/common/libBuffer/CMakeLists.txt
+===================================================================
+--- OpenCOLLADA-69b844dc9eea0a014326149c259e7810ecec4c8c.orig/common/libBuffer/CMakeLists.txt
++++ OpenCOLLADA-69b844dc9eea0a014326149c259e7810ecec4c8c/common/libBuffer/CMakeLists.txt
+@@ -28,7 +28,10 @@ set(SRC
+ include/performanceTest/performanceTest.h
+ )
+
+-set(TARGET_LIBS ftoa)
++set(TARGET_LIBS
++ ftoa
++ UTF
++)
+
+ include_directories(
+ ${libBuffer_include_dirs}
+Index: OpenCOLLADA-69b844dc9eea0a014326149c259e7810ecec4c8c/CMakeLists.txt
+===================================================================
+--- OpenCOLLADA-69b844dc9eea0a014326149c259e7810ecec4c8c.orig/CMakeLists.txt
++++ OpenCOLLADA-69b844dc9eea0a014326149c259e7810ecec4c8c/CMakeLists.txt
+@@ -244,10 +244,10 @@ else () # if pcre not found building it
+ endif ()
+
+ # building required libs
++add_subdirectory(${EXTERNAL_LIBRARIES}/UTF)
++add_subdirectory(${EXTERNAL_LIBRARIES}/MathMLSolver)
+ add_subdirectory(common/libftoa)
+ add_subdirectory(common/libBuffer)
+-add_subdirectory(${EXTERNAL_LIBRARIES}/UTF)
+-add_subdirectory(${EXTERNAL_LIBRARIES}/MathMLSolver)
+
+ # building OpenCOLLADA libs
+ add_subdirectory(COLLADABaseUtils)