summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/plib/plib-1.8.5.ebuild')
-rw-r--r--media-libs/plib/plib-1.8.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/plib/plib-1.8.5.ebuild b/media-libs/plib/plib-1.8.5.ebuild
new file mode 100644
index 000000000000..09e2d48d8afd
--- /dev/null
+++ b/media-libs/plib/plib-1.8.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="multimedia library used by many games"
+HOMEPAGE="http://plib.sourceforge.net/"
+SRC_URI="http://plib.sourceforge.net/dist/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc sparc x86"
+
+DEPEND="virtual/opengl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-X11.patch
+ eautoreconf
+ # Since plib only provides static libraries, force
+ # building as PIC or plib is useless to amd64/etc...
+ append-flags -fPIC
+}
+
+src_install() {
+ default
+ dodoc AUTHORS ChangeLog KNOWN_BUGS NOTICE README* TODO*
+}