summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/streamdeck-ui/streamdeck-ui-9999.ebuild')
-rw-r--r--media-video/streamdeck-ui/streamdeck-ui-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-video/streamdeck-ui/streamdeck-ui-9999.ebuild b/media-video/streamdeck-ui/streamdeck-ui-9999.ebuild
new file mode 100644
index 000000000000..310b80a78328
--- /dev/null
+++ b/media-video/streamdeck-ui/streamdeck-ui-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="A Linux compatible UI for the Elgato Stream Deck"
+HOMEPAGE="https://github.com/timothycrosley/streamdeck-ui"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/timothycrosley/streamdeck-ui.git"
+else
+ COMMIT="9b6678d2d3027963ddac147ee3aeda322ec77f29"
+ SRC_URI="https://github.com/timothycrosley/streamdeck-ui/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pynput[${PYTHON_USEDEP}]
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ media-libs/elgato-streamdeck[${PYTHON_USEDEP}]
+ dev-libs/hidapi"
+RDEPEND="${DEPEND}"