summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/openl2tp/files/openl2tp-1.8-cflags.patch')
-rw-r--r--net-dialup/openl2tp/files/openl2tp-1.8-cflags.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-dialup/openl2tp/files/openl2tp-1.8-cflags.patch b/net-dialup/openl2tp/files/openl2tp-1.8-cflags.patch
new file mode 100644
index 000000000000..fe8825766ea9
--- /dev/null
+++ b/net-dialup/openl2tp/files/openl2tp-1.8-cflags.patch
@@ -0,0 +1,34 @@
+diff -Naurd openl2tp-1.8.orig/Makefile openl2tp-1.8/Makefile
+--- openl2tp-1.8.orig/Makefile 2018-07-03 04:59:51.000000000 +0900
++++ openl2tp-1.8/Makefile 2018-07-03 05:00:44.133460163 +0900
+@@ -155,24 +155,23 @@
+ endif
+
+ CPPFLAGS= $(CPPFLAGS.l2tptest) $(CPPFLAGS-y)
+-CFLAGS= -I. -Iusl -Icli -isystem include \
++CFLAGS+= -I. -Iusl -Icli -isystem include \
+ -MMD -Wall -Wno-strict-aliasing \
+ $(CPPFLAGS) $(CPPFLAGS.dmalloc) \
+ -DSYS_LIBDIR=$(SYS_LIBDIR)
+ LDFLAGS.l2tpd= -Wl,-E -L. -Lusl -lusl -ldl $(LIBS.dmalloc) -lc
+ LDFLAGS.l2tpconfig= -Lcli -lcli -lreadline $(LIBS.dmalloc) $(READLINE_LDFLAGS) -lc
+
+-OPT_CFLAGS?= -O
+-
+ ifeq ($(L2TP_DEBUG),y)
+-CFLAGS.optimize= -g
+-CFLAGS.optimize+= -DDEBUG
++CFLAGS.opt= -g
++CFLAGS.opt+= -DDEBUG
+ else
+-CFLAGS.optimize= $(OPT_CFLAGS)
++CFLAGS.opt= $(OPT_CFLAGS)
+ endif
++CFLAGS.optimize= $(CFLAGS) $(CFLAGS.opt)
+ export CFLAGS.optimize
+
+-CFLAGS+= $(CFLAGS.optimize)
++CFLAGS+= $(CFLAGS.opt)
+
+ ifeq ($(L2TP_USE_ASYNC_RPC),y)
+ CPPFLAGS+= -DL2TP_ASYNC_RPC