summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/ez-ipupdate/ez-ipupdate-3.0.11.13.3_beta8-r3.ebuild')
-rw-r--r--net-dns/ez-ipupdate/ez-ipupdate-3.0.11.13.3_beta8-r3.ebuild64
1 files changed, 29 insertions, 35 deletions
diff --git a/net-dns/ez-ipupdate/ez-ipupdate-3.0.11.13.3_beta8-r3.ebuild b/net-dns/ez-ipupdate/ez-ipupdate-3.0.11.13.3_beta8-r3.ebuild
index c264e1c1aba0..0f1e0db86e0e 100644
--- a/net-dns/ez-ipupdate/ez-ipupdate-3.0.11.13.3_beta8-r3.ebuild
+++ b/net-dns/ez-ipupdate/ez-ipupdate-3.0.11.13.3_beta8-r3.ebuild
@@ -1,27 +1,22 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-inherit eutils readme.gentoo systemd user versionator
+EAPI=7
-MY_BETA="$(get_version_component_range 6)"
-MY_PATCH="$(get_version_component_range 4-5)"
-MY_PV="$(get_version_component_range 1-3)${MY_BETA/beta/b}"
+MY_BETA="$(ver_cut 6-)"
+MY_PATCH="$(ver_cut 4-5)"
+MY_PV="$(ver_cut 1-3)${MY_BETA/beta/b}"
+inherit readme.gentoo-r1 systemd user
DESCRIPTION="Dynamic DNS client for lots of dynamic dns services"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="mirror://debian/pool/main/e/ez-ipupdate/${PN}_${MY_PV}.orig.tar.gz
mirror://debian/pool/main/e/ez-ipupdate/${PN}_${MY_PV}-${MY_PATCH}.diff.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${PN}-${MY_PV}"
DISABLE_AUTOFORMATTING="yes"
DOC_CONTENTS="
@@ -44,35 +39,34 @@ init-script with the 'update' parameter inside
your PPP ip-up script.
"
-src_prepare() {
- # apply debian patches
- epatch "${WORKDIR}/${PN}_${MY_PV}-${MY_PATCH}.diff"
-
- # repair/apply additional debian patches
- sed -i -e "s|^\(---\s*\)\.\./|\1|g" debian/patches/*.diff
- EPATCH_SOURCE="${S}/debian/patches" EPATCH_SUFFIX="diff" EPATCH_FORCE="yes" epatch
-
+PATCHES=(
# adding members.3322.org support
- epatch "${FILESDIR}/${P}-3322.diff"
-
+ "${FILESDIR}/${P}-3322.diff"
# adding www.dnsexit.com support
- epatch "${FILESDIR}/${P}-dnsexit.diff"
-
+ "${FILESDIR}/${P}-dnsexit.diff"
# make ez-ipupdate work with iproute2/dhcpcd under linux (bug #318905)
- epatch "${FILESDIR}/${P}-linux.diff"
-
+ "${FILESDIR}/${P}-linux.diff"
# allows to set IPv6 via -a option, (bug #432764)
- epatch "${FILESDIR}/${P}-ipv6.diff"
-
+ "${FILESDIR}/${P}-ipv6.diff"
# repair format mask issues
- sed -i -e "s|\(\s*\)\(strlen(putbuf)\)|\1(int)\2|g" ez-ipupdate.c || die
+ "${FILESDIR}/${P}-fix-format-mask.patch"
+)
+
+src_prepare() {
+ # Debian patches
+ eapply "${WORKDIR}/${PN}_${MY_PV}-${MY_PATCH}.diff"
+ # repair/apply additional Debian patches
+ sed -i -e "s|^\(---\s*\)\.\./|\1|g" debian/patches/*.diff || die
+ eapply debian/patches
+
+ default
# comment out obsolete options
sed -i -e "s:^\(run-as-user.*\):#\1:g" \
-e "s:^\(cache-file.*\):#\1:g" ex*conf || die
# make 'missing' executable (bug #103480)
- chmod +x missing
+ chmod +x missing || die
}
src_configure() {
@@ -105,17 +99,17 @@ pkg_preinst() {
}
pkg_postinst() {
- chmod 750 /etc/ez-ipupdate /var/cache/ez-ipupdate
- chown ez-ipupd:ez-ipupd /etc/ez-ipupdate /var/cache/ez-ipupdate
+ chmod 750 /etc/ez-ipupdate /var/cache/ez-ipupdate || die
+ chown ez-ipupd:ez-ipupd /etc/ez-ipupdate /var/cache/ez-ipupdate || die
readme.gentoo_print_elog
- if [ -f /etc/ez-ipupdate.conf ]; then
+ if [[ -f /etc/ez-ipupdate.conf ]]; then
elog "The ez-ipupdate init-script can now handle more"
elog "than one config file. New config file location is"
elog "/etc/ez-ipupdate/*.conf"
- if [ ! -f /etc/ez-ipupdate/default.conf ]; then
- mv -f /etc/ez-ipupdate.conf /etc/ez-ipupdate/default.conf
+ if [[ ! -f /etc/ez-ipupdate/default.conf ]]; then
+ mv -f /etc/ez-ipupdate.conf /etc/ez-ipupdate/default.conf || die
elog "Your old configuration has been moved to"
elog "/etc/ez-ipupdate/default.conf"
fi