summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild')
-rw-r--r--net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild b/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild
new file mode 100644
index 000000000000..c7003379c001
--- /dev/null
+++ b/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/aarond10/https_dns_proxy.git"
+ inherit git-r3
+else
+ MY_COMMIT="2d9285e2b94bce21c588c8160f8fac660806987a"
+ SRC_URI="https://github.com/aarond10/https_dns_proxy/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_COMMIT}"
+fi
+
+DESCRIPTION="A lightweight DNS-over-HTTPS proxy"
+HOMEPAGE="https://github.com/aarond10/https_dns_proxy"
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="dev-libs/libev
+ net-dns/c-ares
+ net-misc/curl[http2,ssl]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ dobin "${WORKDIR}/${P}_build/https_dns_proxy"
+}