summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/rb_libtorrent/rb_libtorrent-1.1.2.ebuild')
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-1.1.2.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-1.1.2.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-1.1.2.ebuild
index c3a54a8c6d7c..5a8412d4f63d 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-1.1.2.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-1.1.2.ebuild
@@ -71,12 +71,10 @@ src_configure() {
econf "${myeconfargs[@]}"
if use python; then
- myeconfargs+=(
- --enable-python-binding
- --with-boost-python
- )
python_configure() {
- econf "${myeconfargs[@]}"
+ econf "${myeconfargs[@]}" \
+ --enable-python-binding \
+ --with-boost-python="${EPYTHON#python}"
}
distutils-r1_src_configure
fi