summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mu')
-rw-r--r--net-mail/mu/Manifest2
-rw-r--r--net-mail/mu/mu-1.4.10.ebuild91
-rw-r--r--net-mail/mu/mu-1.4.12.ebuild91
3 files changed, 0 insertions, 184 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index 1d103ca7eca7..d2d96b0efc6b 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1,3 +1 @@
-DIST mu-1.4.10.tar.gz 2309459 BLAKE2B 38aa09e1efd788f1ed0d490dfba04bf4f3fccf1eb40d22d2d205934ab6d71ec8739d1baa019ba4c9a0593a0d9487533a46048f71be042178bd33bde6130cbb80 SHA512 59c06e1a0bc893c7dcf5e758dad15be80667be8bb914e97f16158709ebfd50ca29b3a27934bc2df29cc378ce17a3778c5c44738703aa77f5bde21050abb6eb0c
-DIST mu-1.4.12.tar.gz 2309385 BLAKE2B 4f1b7c520a38e5f17471c2a9dc814decc019a4afce89d642ecbaee988752bc20a7f525809a6d911cbc46dadbbeb5db126f7d01465e3dc18ffb099ad1159d3839 SHA512 7e376a58fed80ed1110ad342e3578a427779d4fd715990ce5b87d50b6c2488774b47f9b151dca80bb8723eee8db99699f97df975d199dae0d75576f5c2ebc35a
DIST mu-1.4.13.tar.gz 2309545 BLAKE2B 9a83e86ab73e325617694f01877a11a93a5bd701cedc776640563f0a5e61946064e201d3f5da2110e1f9583dde9a73e401dd2f018161380435f48f132b2df103 SHA512 0f8e7f75332257e8cfdecf2c27bc23c83420387e40ecf92089232af6c545700a6c4925665b39fc236cacf8b26fa4b81df71775cdbe04c340fe3455c54c0d1bbc
diff --git a/net-mail/mu/mu-1.4.10.ebuild b/net-mail/mu/mu-1.4.10.ebuild
deleted file mode 100644
index fe038e53b674..000000000000
--- a/net-mail/mu/mu-1.4.10.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools elisp-common
-
-DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
-HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
-SRC_URI="https://github.com/djcb/mu/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="emacs guile mug"
-
-DEPEND="
- dev-libs/glib:2
- dev-libs/gmime:3.0
- >=dev-libs/xapian-1.4
- emacs? ( >=app-editors/emacs-24.4:* )
- guile? ( >=dev-scheme/guile-2.2 )
- mug? (
- net-libs/webkit-gtk:4
- x11-libs/gtk+:3
- )"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-SITEFILE="70mu-gentoo-autoload.el"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable emacs mu4e)
- $(use_enable mug gtk)
- $(use_enable mug webkit)
- $(use_enable guile)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- dobin mu/mu
- dodoc AUTHORS HACKING NEWS NEWS.org TODO README ChangeLog
- if use emacs; then
- elisp-install ${PN} mu4e/*.el mu4e/*.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- doinfo mu4e/mu4e.info
- fi
-
- doman man/mu-*.*
-
- if use guile; then
- doinfo guile/mu-guile.info
- fi
-
- if use mug; then
- dobin toys/mug/mug
- fi
-}
-
-src_test() {
- emake check
-}
-
-pkg_preinst() {
- if [[ -n ${REPLACING_VERSIONS} ]]; then
- elog "After upgrading from an old major version, you should"
- elog "rebuild your mail index."
- fi
-}
-
-pkg_postinst() {
- if use emacs; then
- einfo "To use mu4e you need to configure it in your .emacs file"
- einfo "See the manual for more information:"
- einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
- fi
-
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/net-mail/mu/mu-1.4.12.ebuild b/net-mail/mu/mu-1.4.12.ebuild
deleted file mode 100644
index 99919703af77..000000000000
--- a/net-mail/mu/mu-1.4.12.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools elisp-common
-
-DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
-HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
-SRC_URI="https://github.com/djcb/mu/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="emacs guile mug"
-
-DEPEND="
- dev-libs/glib:2
- dev-libs/gmime:3.0
- >=dev-libs/xapian-1.4
- emacs? ( >=app-editors/emacs-24.4:* )
- guile? ( >=dev-scheme/guile-2.2 )
- mug? (
- net-libs/webkit-gtk:4
- x11-libs/gtk+:3
- )"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-SITEFILE="70mu-gentoo-autoload.el"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable emacs mu4e)
- $(use_enable mug gtk)
- $(use_enable mug webkit)
- $(use_enable guile)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- dobin mu/mu
- dodoc AUTHORS HACKING NEWS NEWS.org TODO README ChangeLog
- if use emacs; then
- elisp-install ${PN} mu4e/*.el mu4e/*.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- doinfo mu4e/mu4e.info
- fi
-
- doman man/mu-*.*
-
- if use guile; then
- doinfo guile/mu-guile.info
- fi
-
- if use mug; then
- dobin toys/mug/mug
- fi
-}
-
-src_test() {
- emake check
-}
-
-pkg_preinst() {
- if [[ -n ${REPLACING_VERSIONS} ]]; then
- elog "After upgrading from an old major version, you should"
- elog "rebuild your mail index."
- fi
-}
-
-pkg_postinst() {
- if use emacs; then
- einfo "To use mu4e you need to configure it in your .emacs file"
- einfo "See the manual for more information:"
- einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
- fi
-
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}