summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/datapipe/datapipe-1.0-r1.ebuild')
-rw-r--r--net-misc/datapipe/datapipe-1.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-misc/datapipe/datapipe-1.0-r1.ebuild b/net-misc/datapipe/datapipe-1.0-r1.ebuild
new file mode 100644
index 000000000000..1bf5bdfb7769
--- /dev/null
+++ b/net-misc/datapipe/datapipe-1.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+IUSE=""
+DESCRIPTION="bind a local port and connect it to a remote socket"
+HOMEPAGE="http://http.distributed.net/pub/dcti/unsupported/"
+SRC_URI="ftp://ftp.distributed.net/pub/dcti/unsupported/${P}.tar.gz http://http.distributed.net/pub/dcti/unsupported/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~arm ~amd64"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o datapipe datapipe.c
+}
+
+src_install() {
+ dobin datapipe
+ dodoc datapipe.txt
+}