summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openssh/openssh-8.0_p1-r1.ebuild')
-rw-r--r--net-misc/openssh/openssh-8.0_p1-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-misc/openssh/openssh-8.0_p1-r1.ebuild b/net-misc/openssh/openssh-8.0_p1-r1.ebuild
index b0bcb15646df..c541630005b9 100644
--- a/net-misc/openssh/openssh-8.0_p1-r1.ebuild
+++ b/net-misc/openssh/openssh-8.0_p1-r1.ebuild
@@ -293,8 +293,8 @@ src_configure() {
$(use_with !elibc_Cygwin hardening) #659210
)
- # stackprotect is broken on musl x86
- use elibc_musl && use x86 && myconf+=( --without-stackprotect )
+ # stackprotect is broken on musl x86 and ppc
+ use elibc_musl && ( use x86 || use ppc ) && myconf+=( --without-stackprotect )
# The seccomp sandbox is broken on x32, so use the older method for now. #553748
use amd64 && [[ ${ABI} == "x32" ]] && myconf+=( --with-sandbox=rlimit )