summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/spiped')
-rw-r--r--net-misc/spiped/Manifest1
-rw-r--r--net-misc/spiped/files/spiped.confd21
-rw-r--r--net-misc/spiped/files/spiped.initd46
-rw-r--r--net-misc/spiped/metadata.xml15
-rw-r--r--net-misc/spiped/spiped-1.5.0.ebuild38
5 files changed, 121 insertions, 0 deletions
diff --git a/net-misc/spiped/Manifest b/net-misc/spiped/Manifest
new file mode 100644
index 000000000000..cee6d4cfcbc2
--- /dev/null
+++ b/net-misc/spiped/Manifest
@@ -0,0 +1 @@
+DIST spiped-1.5.0.tgz 68813 SHA256 b2f74b34fb62fd37d6e2bfc969a209c039b88847e853a49e91768dec625facd7 SHA512 55e9f18fc82415d28f44af538c6dd8c222798f6ac719a9ad43772357c0f05f281a883cf1189552deeb4b646abe3d060089d66b5f2ba66b5a2a82627dc62513cc WHIRLPOOL be07cfd67a21dfafc37a1d514193c3f45f9f9cb41a3009d50ad564f39fdde1342d2b716baca2b67040b0a75a9b3d469f372c6cc861c3376117d31d7ec4e4b0b3
diff --git a/net-misc/spiped/files/spiped.confd b/net-misc/spiped/files/spiped.confd
new file mode 100644
index 000000000000..117be90309c3
--- /dev/null
+++ b/net-misc/spiped/files/spiped.confd
@@ -0,0 +1,21 @@
+# /etc/conf.d/spiped
+
+# Once you're happy with your settings,
+# set IS_CONFIGURED to "yes".
+IS_CONFIGURED="no"
+
+# spiped is shipped with plenty of options.
+# Please see the man page for the complete list.
+# -e : encrypt communication
+# -d : decrypt communication
+OPTS="-e"
+
+# Address and port on which spiped should listen for incoming connections.
+# If you want it to listen on the loopback interface, do not specify "localhost"
+# but the localhost IP address instead. spiped won't start if you do so.
+SRCHOST="127.0.0.1"
+SRCPORT="12345"
+
+# Address and port to which spiped should connect
+TARGETHOST="some.domain.tld"
+TARGETPORT="1337"
diff --git a/net-misc/spiped/files/spiped.initd b/net-misc/spiped/files/spiped.initd
new file mode 100644
index 000000000000..1fe07b5e0350
--- /dev/null
+++ b/net-misc/spiped/files/spiped.initd
@@ -0,0 +1,46 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+KEYFILE=${KEYFILE:="/etc/spiped/keyfile"}
+SPIPED_USER=${SPIPED_USER:="nobody"}
+PIDFILE="/run/spiped/spiped.pid"
+
+command="spiped"
+command_args="${OPTS} -s [${SRCHOST}]:${SRCPORT} -t ${TARGETHOST}:${TARGETPORT} -k ${KEYFILE} -p ${PIDFILE}"
+
+depend() {
+ use net
+ before logger
+}
+
+checkconfig() {
+ if [[ ! "$IS_CONFIGURED" == "yes" ]]; then
+ eerror "You need to setup /etc/conf.d/spiped first!"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting ${SVCNAME}"
+ checkpath -d -o "${SPIPED_USER}" -m750 "$(dirname "${PIDFILE}")"
+
+ start-stop-daemon --start \
+ --user ${SPIPED_USER} \
+ --pidfile ${PIDFILE} \
+ --exec $command -- $command_args
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+
+ start-stop-daemon --stop \
+ --pidfile ${PIDFILE}
+
+ eend $?
+}
diff --git a/net-misc/spiped/metadata.xml b/net-misc/spiped/metadata.xml
new file mode 100644
index 000000000000..1b2d73180213
--- /dev/null
+++ b/net-misc/spiped/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Spiped (pronounced "ess-pipe-dee") is a utility for creating symmetrically
+ encrypted and authenticated pipes between socket addresses, so that one may
+ connect to one address (e.g., a UNIX socket on localhost) and transparently
+ have a connection established to another address (e.g., a UNIX socket on a
+ different system). This is similar to 'ssh -L' functionality, but does not
+ use SSH and requires a pre-shared symmetric key.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-misc/spiped/spiped-1.5.0.ebuild b/net-misc/spiped/spiped-1.5.0.ebuild
new file mode 100644
index 000000000000..9a62bf2bb7e1
--- /dev/null
+++ b/net-misc/spiped/spiped-1.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="secure pipe daemon"
+HOMEPAGE="http://www.tarsnap.com/spiped.html"
+SRC_URI="http://www.tarsnap.com/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl:*"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin spipe/spipe
+ dosbin spiped/spiped
+
+ doman spipe/spipe.1 spiped/spiped.1
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ dodir etc/spiped
+}
+
+pkg_postinst() {
+ elog
+ elog "You will need to configure spiped via its"
+ elog "configuration file located in /etc/conf.d/."
+ elog
+ elog "Please have a look at this file prior to starting up spiped!"
+ elog
+}