summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/biglybt/biglybt-3.6.0.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-p2p/biglybt/biglybt-3.6.0.0.ebuild b/net-p2p/biglybt/biglybt-3.6.0.0.ebuild
index 9cacc9c9454c..4ee04bea7849 100644
--- a/net-p2p/biglybt/biglybt-3.6.0.0.ebuild
+++ b/net-p2p/biglybt/biglybt-3.6.0.0.ebuild
@@ -7,7 +7,7 @@ EAPI=8
JAVA_PKG_IUSE="doc source"
MAVEN_PROVIDES="com.${PN}:${PN}-core:${PV} com.${PN}:${PN}-ui:${PV}"
-inherit desktop java-pkg-2 java-pkg-simple xdg
+inherit desktop java-pkg-2 java-pkg-simple optfeature xdg
DESCRIPTION="Feature-filled Bittorrent client based on the Azureus open source project"
HOMEPAGE="https://www.biglybt.com"
@@ -100,3 +100,11 @@ src_install() {
fi
default
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature_header "If you are using plugin proxies you might want to swap them for these native packages:"
+ optfeature "I2P SOCKS proxy" net-vpn/i2p net-vpn/i2pd
+ optfeature "TOR SOCKS proxy" net-vpn/tor
+}