summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/flashdot/flashdot-1.1.4.ebuild')
-rw-r--r--sci-misc/flashdot/flashdot-1.1.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-misc/flashdot/flashdot-1.1.4.ebuild b/sci-misc/flashdot/flashdot-1.1.4.ebuild
new file mode 100644
index 000000000000..2711ac0dc461
--- /dev/null
+++ b/sci-misc/flashdot/flashdot-1.1.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="Generator for psychophysical experiments"
+HOMEPAGE="http://www.flashdot.info/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~tomka/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
+ dev-ml/ocamlsdl
+ dev-ml/ocamlgsl
+ dev-ml/lablgl[glut]
+ x11-apps/xdpyinfo"
+RDEPEND="${DEPEND}"
+
+MAKEOPTS="-j1 VERSION=${PV}"
+use ocamlopt || MAKEOPTS="${MAKEOPTS} TARGETS=flashdot_bytecode BYTECODENAME=flashdot"
+
+src_compile() {
+ emake ${MAKEOPTS} || die "emake failed"
+}
+
+src_install() {
+ emake ${MAKEOPTS} DESTDIR="${D}" CALLMODE=script install || die "install failed"
+}