summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/palo/palo-1.92.ebuild')
-rw-r--r--sys-boot/palo/palo-1.92.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/sys-boot/palo/palo-1.92.ebuild b/sys-boot/palo/palo-1.92.ebuild
deleted file mode 100644
index 6ee80b6caaa8..000000000000
--- a/sys-boot/palo/palo-1.92.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="PALO : PArisc Linux Loader"
-HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
-SRC_URI="https://dev.gentoo.org/~jer/${P/-/_}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* hppa"
-IUSE=""
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-1.92-toolchain.patch
- sed -i palo/Makefile -e '/^LDFLAGS=/d' || die
-}
-
-src_compile() {
- local target
- for target in '-C palo' '-C ipl' 'iplboot'; do
- emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
- done
-}
-
-src_install() {
- into /
- dosbin palo/palo
-
- doman palo.8
- dohtml README.html
- dodoc Changes TODO debian/changelog
-
- insinto /etc
- doins "${FILESDIR}"/palo.conf
-
- insinto /usr/share/palo
- doins iplboot
-
- insinto /etc/kernel/postinst.d/
- INSOPTIONS="-m 0744" doins "${FILESDIR}"/99palo
-}