summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/kbdd/kbdd-0.5.2.ebuild')
-rw-r--r--x11-misc/kbdd/kbdd-0.5.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/kbdd/kbdd-0.5.2.ebuild b/x11-misc/kbdd/kbdd-0.5.2.ebuild
new file mode 100644
index 000000000000..7c4536b86c65
--- /dev/null
+++ b/x11-misc/kbdd/kbdd-0.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="Very simple layout switcher"
+HOMEPAGE="http://github.com/qnikst/kbdd"
+SRC_URI="https://github.com/qnikst/kbdd/tarball/v${PV} -> ${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+DEPEND="dev-libs/glib
+ x11-libs/libX11
+ dbus? (
+ sys-apps/dbus
+ >=dev-libs/dbus-glib-0.86
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ cd "${WORKDIR}"/qnikst-kbdd-*
+ S=$(pwd)
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable dbus) || die "econf failed"
+}