aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorILMostro <ilmostro7@gmail.com>2018-06-20 01:03:09 -0500
committerILMostro <ilmostro7@gmail.com>2018-06-20 01:03:09 -0500
commit4fe033e50bd7e3807eb6298215d1a41078524bda (patch)
tree6ce7c01158f8b735f53f6571633423ff206bffb3
parentmake sure to include `${DESTDIR}` (diff)
downloadag-ops-4fe033e50bd7e3807eb6298215d1a41078524bda.tar.gz
ag-ops-4fe033e50bd7e3807eb6298215d1a41078524bda.tar.bz2
ag-ops-4fe033e50bd7e3807eb6298215d1a41078524bda.zip
Ensure that penlight modules get installed to the respective lua-version subdirectory;
e.g. `/usr/share/lua/5.3/pl`, rather than `/usr/shar/lua/pl`.
-rw-r--r--dev-lua/penlight/penlight-1.5.4.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-lua/penlight/penlight-1.5.4.ebuild b/dev-lua/penlight/penlight-1.5.4.ebuild
index 1af4e5d..98df2be 100644
--- a/dev-lua/penlight/penlight-1.5.4.ebuild
+++ b/dev-lua/penlight/penlight-1.5.4.ebuild
@@ -24,6 +24,7 @@ RDEPEND="${COMMON_DEPEND}
S="${WORKDIR}/Penlight-${PV}"
src_install() {
- insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ LUA_VERSION=$(readlink -e "${EROOT}"/usr/bin/lua | sed -ne 's:.*/usr/bin/lua\([\d.-]*\):\1:p')
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)/$LUA_VERSION"
doins -r lua/pl
}