aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrei Horodniceanu <a.horodniceanu@proton.me>2024-11-05 12:30:36 +0200
committerAndrei Horodniceanu <a.horodniceanu@proton.me>2024-11-08 16:49:16 +0200
commitca9e5b8d21106fc8b120a634b2760c4c5af7311a (patch)
treecce03993daf87338017bfcfa8aa10c663f82e69c /dev-lang/dmd
parentapp-eselect/eselect-dlang: add 20241105 (diff)
downloaddlang-master.tar.gz
dlang-master.tar.bz2
dlang-master.zip
dev-lang/dmd: add 9999HEADmaster
Closes: https://github.com/gentoo/dlang/issues/132 Signed-off-by: Andrei Horodniceanu <a.horodniceanu@proton.me>
Diffstat (limited to 'dev-lang/dmd')
-rw-r--r--dev-lang/dmd/dmd-9999.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-lang/dmd/dmd-9999.ebuild b/dev-lang/dmd/dmd-9999.ebuild
new file mode 100644
index 0000000..1105fc8
--- /dev/null
+++ b/dev-lang/dmd/dmd-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="-* ~amd64 ~x86"
+else
+ BOOTSTRAP_VERSION=2.109.1
+fi
+DLANG_COMPAT=( dmd-2_{106..109} gdc-1{3,4} ldc2-1_{35..39} )
+
+inherit dmd-r1
+
+# Support the 9999 directory name in /usr/lib/dmd instead of 2.XXX
+[[ ${PV} == *9999* ]] && IDEPEND=">=app-eselect/eselect-dlang-20241105"
+
+PATCHES=(
+ "${FILESDIR}/2.107-dmd-r1-link-32-bit-shared-lib-with-ld.bfd.patch"
+)