aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorodniceanu Andrei <a.horodniceanu@proton.me>2023-10-02 16:21:12 +0300
committerHorodniceanu Andrei <a.horodniceanu@proton.me>2023-10-02 16:21:12 +0300
commit51b17ebd4e6bf15885aca98409fc17905f91dbba (patch)
tree1e838b18e0b01abccab8623e60d99d38e0a984c2 /dev-lang/dmd
parentdev-lang/dmd: add 2.103.1 (diff)
downloaddlang-51b17ebd4e6bf15885aca98409fc17905f91dbba.tar.gz
dlang-51b17ebd4e6bf15885aca98409fc17905f91dbba.tar.bz2
dlang-51b17ebd4e6bf15885aca98409fc17905f91dbba.zip
dev-lang/dmd: add 2.104.2
Signed-off-by: Horodniceanu Andrei <a.horodniceanu@proton.me>
Diffstat (limited to 'dev-lang/dmd')
-rw-r--r--dev-lang/dmd/Manifest1
-rw-r--r--dev-lang/dmd/dmd-2.104.2.ebuild16
2 files changed, 17 insertions, 0 deletions
diff --git a/dev-lang/dmd/Manifest b/dev-lang/dmd/Manifest
index 097f1da..2b896ed 100644
--- a/dev-lang/dmd/Manifest
+++ b/dev-lang/dmd/Manifest
@@ -38,3 +38,4 @@ DIST dmd.2.100.2.linux.tar.xz 22013684 BLAKE2B e7e10ebc91a4baeda917b91e40b7b5d27
DIST dmd.2.101.2.linux.tar.xz 22666828 BLAKE2B 8233d9f375291d73530a677cd5180153bc758076fd135c420cbb088bf84147fa1f0dc1cd563e94737e781823db26e4e0250af31d68819c3375224a92e53876b6 SHA512 7e1ce980fce7a2a995af92b2e05acdfcb2d8abc14780e11d8234792b80edead68c455e644e1830d360651bdacefa1aace963ce652fbfd3b0951dd9002fcfb87f
DIST dmd.2.102.2.linux.tar.xz 22699620 BLAKE2B b0a8fc0650bfe5df4a40ccf20d160765a8ed7804915a1049366ff8b4044d7036ca7f27c8bc71146dc33bf60bf03bc09a9bd8758b9850b020480774f130325abd SHA512 a2dab6efe46176bed0dca98fcf590c6823be9e4d5ca89bce0ff088e7c59a63f8eb4bb3742df1975cc90b5efd78c11377e682b0083fe44c394a73161cbb2b3aa3
DIST dmd.2.103.1.linux.tar.xz 22747324 BLAKE2B b00f41b4ab48be9c5467342314995e69332d4c8bff86083474a940431721d179d5e5ef64734f355df2d96637983de2262d45516594434ad3ad6c4d57a0d7a54c SHA512 854cf08d715506bd36d791c1471f2dd1d834f439bdf4489b4addf0cc5abdecbefceb966baeb764eb5ca816a5830ac7374818ba6fbcad24668d011d56a32a1f15
+DIST dmd.2.104.2.linux.tar.xz 22478264 BLAKE2B 6af63d7a5c976ae251bb16d4b48fc354d429730d00ef33a1f81ef4ec9e491486f49e120c376b2c26f3e57a13f956ccf2c31d1511f4d59db399ae613aa62ec785 SHA512 a0e6bb94887950977743545a908d80d040b2a69c48139164f61c591d1678399636538c75c1aba4d9c25cc163ee60023872f6a50c8b84cc6c09394d33c66c1367
diff --git a/dev-lang/dmd/dmd-2.104.2.ebuild b/dev-lang/dmd/dmd-2.104.2.ebuild
new file mode 100644
index 0000000..59e6dc8
--- /dev/null
+++ b/dev-lang/dmd/dmd-2.104.2.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KEYWORDS="-* ~amd64 ~x86"
+YEAR=2023
+DLANG_VERSION_RANGE="2.076-2.080 2.082 2.084-"
+
+inherit dmd
+
+PATCHES=(
+ "${FILESDIR}/2.097-link-32-bit-shared-lib-with-ld.bfd.patch"
+ # See https://github.com/dlang/phobos/pull/8820
+ "${FILESDIR}/2.101-phobos-change-DMD_DIR-meaning.patch"
+)