aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorodniceanu Andrei <a.horodniceanu@protonmail.com>2022-05-10 20:17:19 +0300
committerHorodniceanu Andrei <a.horodniceanu@protonmail.com>2022-05-10 20:17:19 +0300
commit5c52b7f4cfc511b80319711f9f70f841ed85639f (patch)
treecfa560c2352532b985dd0750c78271e276339b29 /dev-lang/dmd
parentMerge branch 'AlexandreFournier' (diff)
downloaddlang-5c52b7f4cfc511b80319711f9f70f841ed85639f.tar.gz
dlang-5c52b7f4cfc511b80319711f9f70f841ed85639f.tar.bz2
dlang-5c52b7f4cfc511b80319711f9f70f841ed85639f.zip
dmd-2.099.1
Signed-off-by: Horodniceanu Andrei <a.horodniceanu@protonmail.com>
Diffstat (limited to 'dev-lang/dmd')
-rw-r--r--dev-lang/dmd/Manifest1
-rw-r--r--dev-lang/dmd/dmd-2.099.1.ebuild14
-rw-r--r--dev-lang/dmd/files/2.097-link-32-bit-shared-lib-with-ld.bfd.patch11
3 files changed, 26 insertions, 0 deletions
diff --git a/dev-lang/dmd/Manifest b/dev-lang/dmd/Manifest
index 7e1917d..171aecb 100644
--- a/dev-lang/dmd/Manifest
+++ b/dev-lang/dmd/Manifest
@@ -31,3 +31,4 @@ DIST dmd.2.093.1.linux.tar.xz 24506488 BLAKE2B 101edbe659ddb3ce6ed0d66762a0d476d
DIST dmd.2.094.2.linux.tar.xz 22232888 BLAKE2B ba3116f3a9fd9516cd1ac792f950d4ba6c27a51631e2f48698f92506daa77b0cb45e238292b0200a85def5013e5272a9d2725f74b85e5cbe1cfabf8fcdb568eb SHA512 a880928aeb6f16dc1dea7ac406cca2f8dfa75030725e5cefc9a48c1cc3e5c884800367efc293d7f9eaceb3c6c6cae2e3baea781786ccb438231c0734267ad0f0
DIST dmd.2.095.1.linux.tar.xz 22602160 BLAKE2B 874f28ab25b486c68707c4b8723ace3be5507162ce36a6c69550b3202b7deeab448bcc5b72e7492a20f9dd01648ed174506baf7460a26cf572db710e62cbf892 SHA512 5bb25551d6e2e9456225d00d9c082db1464e2ebf238f5781abb18daf29d42e62591603b0a044d9f63ddd0407e908f86c370806610d427c5cd7a100f8fbc74cee
DIST dmd.2.096.1.linux.tar.xz 22825496 BLAKE2B 2a7973aaa9c713bfd29e783b459c97f6b6a68e2ce5d0674477997236f15b623ce45517c0ff59e33252e69aa3a70862ca0ec5cb7d077a050dddffef26fda02106 SHA512 de6d291f0abdd9a504522d0094a8d20beb94f6a8bd2c2b92d90267b5494ccd11f8df436b7c4ecc00d56cea0bdbb09d02376c8453e08c636ca92af38ca8fa0dbe
+DIST dmd.2.099.1.linux.tar.xz 21846416 BLAKE2B e5c3baa981af46ce980c80c42729a2db99a44d3f8f464a711c299c0d7c2354c6ba8d607b57a7f6d79d7a99793cd727f1f7e9fd33c49517ea5c9783efcda00518 SHA512 20fbf33dae8e79d07993ca2b1032e86db40dd21e06dcca2ed3f7cfa8921ba25799e0dc534f989ca535d274f2984f7873a186227854d54c21aadfdd671febc43d
diff --git a/dev-lang/dmd/dmd-2.099.1.ebuild b/dev-lang/dmd/dmd-2.099.1.ebuild
new file mode 100644
index 0000000..c63e4fe
--- /dev/null
+++ b/dev-lang/dmd/dmd-2.099.1.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KEYWORDS="-* ~amd64 ~x86"
+YEAR=2022
+DLANG_VERSION_RANGE="2.076-"
+
+inherit dmd
+
+PATCHES=(
+ "${FILESDIR}/2.097-link-32-bit-shared-lib-with-ld.bfd.patch"
+)
diff --git a/dev-lang/dmd/files/2.097-link-32-bit-shared-lib-with-ld.bfd.patch b/dev-lang/dmd/files/2.097-link-32-bit-shared-lib-with-ld.bfd.patch
new file mode 100644
index 0000000..a68fe1f
--- /dev/null
+++ b/dev-lang/dmd/files/2.097-link-32-bit-shared-lib-with-ld.bfd.patch
@@ -0,0 +1,11 @@
+--- dmd2/dmd/src/dmd/link.d
++++ dmd2/dmd/src/dmd/link.d
+@@ -446,6 +446,8 @@ else version (Posix)
+ {
+ if (global.params.dll)
+ argv.push("-shared");
++ if (!target.is64bit)
++ argv.push("-fuse-ld=bfd");
+ }
+ // None of that a.out stuff. Use explicit exe file name, or
+ // generate one from name of first source file.