aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaichi Yamamoto <dev@dyama.net>2024-12-14 11:10:23 +0900
committerAndrei Horodniceanu <a.horodniceanu@proton.me>2024-12-14 19:45:46 +0200
commita6c2e2dbf727d25a0ea0f6fd460592647e62f69d (patch)
tree4caf987a13823c0d2933fbbc572c1c7b7eb3147f /dev-lang/ldc2
parentdev-lang/dmd: add 9999 (diff)
downloaddlang-a6c2e2dbf727d25a0ea0f6fd460592647e62f69d.tar.gz
dlang-a6c2e2dbf727d25a0ea0f6fd460592647e62f69d.tar.bz2
dlang-a6c2e2dbf727d25a0ea0f6fd460592647e62f69d.zip
dev-lang/ldc2: update LLVM package name
Signed-off-by: Daichi Yamamoto <dev@dyama.net> Closes: https://github.com/gentoo/dlang/pull/134 Signed-off-by: Andrei Horodniceanu <a.horodniceanu@proton.me>
Diffstat (limited to 'dev-lang/ldc2')
-rw-r--r--dev-lang/ldc2/ldc2-1.32.2-r1.ebuild4
-rw-r--r--dev-lang/ldc2/ldc2-1.33.0-r1.ebuild4
-rw-r--r--dev-lang/ldc2/ldc2-1.34.0-r1.ebuild6
-rw-r--r--dev-lang/ldc2/ldc2-1.35.0-r2.ebuild6
-rw-r--r--dev-lang/ldc2/ldc2-1.36.0-r2.ebuild4
-rw-r--r--dev-lang/ldc2/ldc2-1.37.0.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.38.0.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.39.0.ebuild2
8 files changed, 15 insertions, 15 deletions
diff --git a/dev-lang/ldc2/ldc2-1.32.2-r1.ebuild b/dev-lang/ldc2/ldc2-1.32.2-r1.ebuild
index 5f31254..42a0214 100644
--- a/dev-lang/ldc2/ldc2-1.32.2-r1.ebuild
+++ b/dev-lang/ldc2/ldc2-1.32.2-r1.ebuild
@@ -21,9 +21,9 @@ IUSE="static-libs"
# Upstream supports LLVM 9.0 through 15.0.
RDEPEND="
|| (
- sys-devel/llvm:15
+ llvm-core/llvm:15
)
- <sys-devel/llvm-16:=
+ <llvm-core/llvm-16:=
>=app-eselect/eselect-dlang-20140709"
DEPEND="${RDEPEND}"
LLVM_MAX_SLOT=15
diff --git a/dev-lang/ldc2/ldc2-1.33.0-r1.ebuild b/dev-lang/ldc2/ldc2-1.33.0-r1.ebuild
index 5f31254..42a0214 100644
--- a/dev-lang/ldc2/ldc2-1.33.0-r1.ebuild
+++ b/dev-lang/ldc2/ldc2-1.33.0-r1.ebuild
@@ -21,9 +21,9 @@ IUSE="static-libs"
# Upstream supports LLVM 9.0 through 15.0.
RDEPEND="
|| (
- sys-devel/llvm:15
+ llvm-core/llvm:15
)
- <sys-devel/llvm-16:=
+ <llvm-core/llvm-16:=
>=app-eselect/eselect-dlang-20140709"
DEPEND="${RDEPEND}"
LLVM_MAX_SLOT=15
diff --git a/dev-lang/ldc2/ldc2-1.34.0-r1.ebuild b/dev-lang/ldc2/ldc2-1.34.0-r1.ebuild
index fdbd364..97a044f 100644
--- a/dev-lang/ldc2/ldc2-1.34.0-r1.ebuild
+++ b/dev-lang/ldc2/ldc2-1.34.0-r1.ebuild
@@ -21,10 +21,10 @@ IUSE="static-libs"
# Upstream supports LLVM 11.0 through 16.
RDEPEND="
|| (
- sys-devel/llvm:16
- sys-devel/llvm:15
+ llvm-core/llvm:16
+ llvm-core/llvm:15
)
- <sys-devel/llvm-17:=
+ <llvm-core/llvm-17:=
>=app-eselect/eselect-dlang-20140709"
DEPEND="${RDEPEND}"
LLVM_MAX_SLOT=16
diff --git a/dev-lang/ldc2/ldc2-1.35.0-r2.ebuild b/dev-lang/ldc2/ldc2-1.35.0-r2.ebuild
index aa6edf1..e3dcb7f 100644
--- a/dev-lang/ldc2/ldc2-1.35.0-r2.ebuild
+++ b/dev-lang/ldc2/ldc2-1.35.0-r2.ebuild
@@ -21,10 +21,10 @@ IUSE="static-libs"
# Upstream supports LLVM 11.0 through 16.0.
DEPEND="
|| (
- sys-devel/llvm:16
- sys-devel/llvm:15
+ llvm-core/llvm:16
+ llvm-core/llvm:15
)
- <sys-devel/llvm-17:="
+ <llvm-core/llvm-17:="
IDEPEND=">=app-eselect/eselect-dlang-20140709"
RDEPEND="
${DEPEND}
diff --git a/dev-lang/ldc2/ldc2-1.36.0-r2.ebuild b/dev-lang/ldc2/ldc2-1.36.0-r2.ebuild
index 6e625da..3867d8e 100644
--- a/dev-lang/ldc2/ldc2-1.36.0-r2.ebuild
+++ b/dev-lang/ldc2/ldc2-1.36.0-r2.ebuild
@@ -39,7 +39,7 @@ REQUIRED_USE=${DLANG_REQUIRED_USE}
DEPEND="
${DLANG_DEPS}
$(llvm_gen_dep '
- sys-devel/llvm:${LLVM_SLOT}=
+ llvm-core/llvm:${LLVM_SLOT}=
')
net-misc/curl[${MULTILIB_USEDEP}]
"
@@ -80,7 +80,7 @@ src_prepare(){
src_configure() {
# We disable assertions so we have to apply the same workaround as for
- # sys-devel/llvm: add -DNDEBUG to CPPFLAGS.
+ # llvm-core/llvm: add -DNDEBUG to CPPFLAGS.
local CPPFLAGS="${CPPFLAGS} -DNDEBUG"
# https://bugs.gentoo.org/show_bug.cgi?id=922590
append-flags -fno-strict-aliasing
diff --git a/dev-lang/ldc2/ldc2-1.37.0.ebuild b/dev-lang/ldc2/ldc2-1.37.0.ebuild
index b681cd4..1c1aa12 100644
--- a/dev-lang/ldc2/ldc2-1.37.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.37.0.ebuild
@@ -38,7 +38,7 @@ REQUIRED_USE=${DLANG_REQUIRED_USE}
DEPEND="
${DLANG_DEPS}
$(llvm_gen_dep '
- sys-devel/llvm:${LLVM_SLOT}=
+ llvm-core/llvm:${LLVM_SLOT}=
')
net-misc/curl[${MULTILIB_USEDEP}]
"
diff --git a/dev-lang/ldc2/ldc2-1.38.0.ebuild b/dev-lang/ldc2/ldc2-1.38.0.ebuild
index f4bbac6..a21540b 100644
--- a/dev-lang/ldc2/ldc2-1.38.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.38.0.ebuild
@@ -44,7 +44,7 @@ REQUIRED_USE=${DLANG_REQUIRED_USE}
DEPEND="
${DLANG_DEPS}
$(llvm_gen_dep '
- sys-devel/llvm:${LLVM_SLOT}=
+ llvm-core/llvm:${LLVM_SLOT}=
')
net-misc/curl[${MULTILIB_USEDEP}]
"
diff --git a/dev-lang/ldc2/ldc2-1.39.0.ebuild b/dev-lang/ldc2/ldc2-1.39.0.ebuild
index b1630ae..8b80bb5 100644
--- a/dev-lang/ldc2/ldc2-1.39.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.39.0.ebuild
@@ -44,7 +44,7 @@ REQUIRED_USE=${DLANG_REQUIRED_USE}
DEPEND="
${DLANG_DEPS}
$(llvm_gen_dep '
- sys-devel/llvm:${LLVM_SLOT}=
+ llvm-core/llvm:${LLVM_SLOT}=
')
net-misc/curl[${MULTILIB_USEDEP}]
"