aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorodniceanu Andrei <a.horodniceanu@proton.me>2023-10-15 13:45:36 +0300
committerHorodniceanu Andrei <a.horodniceanu@proton.me>2023-11-17 22:54:30 +0200
commitc4ff5cfc49313068a4591a6e192b50cde40c5f32 (patch)
treeaea58228e4e717863f2bf9bec1290bf759838c02 /dev-libs
parentdev-util/dlang-tools: upgrade to EAPI 8 (diff)
downloaddlang-c4ff5cfc49313068a4591a6e192b50cde40c5f32.tar.gz
dlang-c4ff5cfc49313068a4591a6e192b50cde40c5f32.tar.bz2
dlang-c4ff5cfc49313068a4591a6e192b50cde40c5f32.zip
dev-libs/gtkd: upgrade to EAPI 7, replace unzip calls
Closes: https://github.com/gentoo/dlang/pull/125 Signed-off-by: Horodniceanu Andrei <a.horodniceanu@proton.me>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gtkd/gtkd-2.4.2-r1.ebuild13
-rw-r--r--dev-libs/gtkd/gtkd-3.9.0.ebuild7
2 files changed, 13 insertions, 7 deletions
diff --git a/dev-libs/gtkd/gtkd-2.4.2-r1.ebuild b/dev-libs/gtkd/gtkd-2.4.2-r1.ebuild
index ad07352..16d99d0 100644
--- a/dev-libs/gtkd/gtkd-2.4.2-r1.ebuild
+++ b/dev-libs/gtkd/gtkd-2.4.2-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="D binding and OO wrapper of GTK+ and is released on the LGPL license"
HOMEPAGE="http://gtkd.org/"
@@ -15,9 +15,9 @@ SRC_URI="https://gtkd.org/Downloads/sources/GtkD-${PV}.zip"
DLANG_VERSION_RANGE="2.063-2.067 2.071-2.080"
DLANG_PACKAGE_TYPE="multi"
-inherit eutils dlang
+inherit dlang multilib-build
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
RDEPEND="
>=x11-libs/gtk+-3.10:3[${MULTILIB_USEDEP}]
sourceview? ( >=x11-libs/gtksourceview-3.10:3.0 )
@@ -34,7 +34,10 @@ MAJOR=$(ver_cut 1)
MINOR=$(ver_cut 2-)
src_unpack() {
- unzip -q "${DISTDIR}/${A}" -d "${S}"
+ mkdir "${S}" || die "Could not create source directory"
+ pushd "${S}" >/dev/null
+ unpack "${A}"
+ popd >/dev/null
}
d_src_compile() {
diff --git a/dev-libs/gtkd/gtkd-3.9.0.ebuild b/dev-libs/gtkd/gtkd-3.9.0.ebuild
index bfea972..0d016fb 100644
--- a/dev-libs/gtkd/gtkd-3.9.0.ebuild
+++ b/dev-libs/gtkd/gtkd-3.9.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -39,7 +39,10 @@ MAJOR=$(ver_cut 1)
MINOR=$(ver_cut 2-)
src_unpack() {
- unzip -q "${DISTDIR}/${A}" -d "${S}"
+ mkdir "${S}" || die "Could not create source directory"
+ pushd "${S}" >/dev/null
+ unpack "${DISTDIR}/${A}"
+ popd "${S}" >/dev/null
}
d_src_compile() {