aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/gtkd/gtkd-3.8.5-r1.ebuild')
-rw-r--r--dev-libs/gtkd/gtkd-3.8.5-r1.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-libs/gtkd/gtkd-3.8.5-r1.ebuild b/dev-libs/gtkd/gtkd-3.8.5-r1.ebuild
index acfe068..841f0a9 100644
--- a/dev-libs/gtkd/gtkd-3.8.5-r1.ebuild
+++ b/dev-libs/gtkd/gtkd-3.8.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -81,12 +81,10 @@ d_src_test() {
d_src_install() {
install_libs() {
# Install the shared library version of the component
- if dlang_has_shared_lib_support; then
- local libfile="lib${LIB_NAME}-${MAJOR}.so"
- ln -sf "${libfile}" "${libfile}.0"
- ln -sf "${libfile}" "${libfile}.0.${MINOR}"
- dolib.so "${libfile}.0.${MINOR}" "${libfile}.0" "${libfile}"
- fi
+ local libfile="lib${LIB_NAME}-${MAJOR}.so"
+ ln -sf "${libfile}" "${libfile}.0"
+ ln -sf "${libfile}" "${libfile}.0.${MINOR}"
+ dolib.so "${libfile}.0.${MINOR}" "${libfile}.0" "${libfile}"
# Install the static library version
if use static-libs; then