summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris, Jr. <johnmh@johnmh.me>2024-06-16 20:41:08 -0700
committerJohn M. Harris, Jr. <johnmh@johnmh.me>2024-06-16 20:41:08 -0700
commit8c8868a6ebcfb075a769c542da7367f0735a8202 (patch)
tree91a75dfc013058dec5c950658a0cdacd2e904638
parentgames-strategy/freeorion: Remove ebuild (diff)
downloadjohnmh-8c8868a6ebcfb075a769c542da7367f0735a8202.tar.gz
johnmh-8c8868a6ebcfb075a769c542da7367f0735a8202.tar.bz2
johnmh-8c8868a6ebcfb075a769c542da7367f0735a8202.zip
gui-libs/hyprcursor: Add ebuild
Signed-off-by: John M. Harris, Jr. <johnmh@johnmh.me>
-rw-r--r--gui-libs/hyprcursor/hyprcursor-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/gui-libs/hyprcursor/hyprcursor-9999.ebuild b/gui-libs/hyprcursor/hyprcursor-9999.ebuild
new file mode 100644
index 0000000..6f66f3f
--- /dev/null
+++ b/gui-libs/hyprcursor/hyprcursor-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023-2024 Gentoo Authors
+# Copyright 2024 John M. Harris, Jr.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The hyprland cursor format, library and utilities"
+HOMEPAGE="https://github.com/hyprwm/hyprcursor"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-source"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+# Disable tests since as per upstream, tests require a theme to be installed
+# See also https://github.com/hyprwm/hyprcursor/commit/94361fd8a75178b92c4bb24dcd8c7fac8423acf3
+RESTRICT="test"
+
+RDEPEND="
+ dev-cpp/tomlplusplus
+ >=dev-libs/hyprlang-0.4.2
+ dev-libs/libzip
+ gnome-base/librsvg:2
+ x11-libs/cairo
+"