summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2017-10-05 20:45:42 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2017-10-05 20:45:42 -0400
commit6ae2421132168fd23a553791fa117477f918422d (patch)
treeb3c7537f026f60b430f9486f8caba51736fea4f9 /games-kids
parentdobin instead of doexe (diff)
downloadsuperposition-6ae2421132168fd23a553791fa117477f918422d.tar.gz
superposition-6ae2421132168fd23a553791fa117477f918422d.tar.bz2
superposition-6ae2421132168fd23a553791fa117477f918422d.zip
add byob
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/byob/Manifest4
-rw-r--r--games-kids/byob/byob-3.1.1.ebuild82
-rw-r--r--games-kids/byob/metadata.xml24
3 files changed, 110 insertions, 0 deletions
diff --git a/games-kids/byob/Manifest b/games-kids/byob/Manifest
new file mode 100644
index 0000000..1c73dd2
--- /dev/null
+++ b/games-kids/byob/Manifest
@@ -0,0 +1,4 @@
+DIST BYOB_3_1_1_110519_w_changes.zip 5089482 SHA256 c28241f002b336361b78cfa840ae009779c9eb46389e0a76f26fce117c22bf65 SHA512 da050dbc995d21bcad3b567f68b16a64f0abb3d3265106493aa507cc0ff19917ef56853f05484423c12c734c2d3104bc2b9488db7c8e22ed2f18fafe161bf62a WHIRLPOOL 7e0558622ba6f80528d6e71358a9e18af03d130ba07a4fcd244be627e22cbde5f07c104b6aa7080142ae77b8f9d18b021e7bf07f321b6d8287b11c2b4bb96da1
+DIST byoblib.tgz 7776258 SHA256 87251d5e648c84885e9abc8e157b779f7871245a30068212ded81bdc9698283b SHA512 cbcdd4ccd4e1977844a7fee81e3ea11f0346879933766b4d39662a804bc39460832da75a83b1061840d44bc33de51ac62c1030d6dd3c9002fe1f49d29433038d WHIRLPOOL e4d2d676231a26bc71e6927be00d04cdaf055391bb038a147d60e90c1f4af02006819a59842e82aba1cb581f2f834fad0749d216cb374e1304a0f31f3cb833fb
+EBUILD byob-3.1.1.ebuild 2091 SHA256 b4d2136603744451a9532e2cebe9163517bb472a7b0a328cd4642975da57b216 SHA512 8706aa2da94016ed9b226dde914b5448b21bd416236887bdc4153fed6e33ba67d7a821f95ec423d3dd2a4f1a97f83c030b0e8c5ad252e600af2471d3cacf3f1d WHIRLPOOL 3ac04a70429ec8390c90251ae6545d64755cfeb1686c985d390054aa6a3da626012d22131c2af6752094d8519d2b059434aba7e3fff91f58764feaea93986237
+MISC metadata.xml 1118 SHA256 6bba4a18a3d4447a9180e4a1fed618ab73b9321790e649f5c74d5c24a1b60cf0 SHA512 656f0b03ef7535547deba9a6457ec1f13ffc999d5ae4d1746e396a972ad97896eae201192daab83d4699fb3c2dc9bb3a2c74898fa8309bdc3231d3bfb54652d4 WHIRLPOOL 689a94ea22526bfa732292c02986890bf47236ac6f6cdcdccea7ee6e94755545601dfcb139bdbc30ce6aa5c5c6161c74c059396621f37cfc0ec37a2601be7ce5
diff --git a/games-kids/byob/byob-3.1.1.ebuild b/games-kids/byob/byob-3.1.1.ebuild
new file mode 100644
index 0000000..422d127
--- /dev/null
+++ b/games-kids/byob/byob-3.1.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils fdo-mime
+
+DESCRIPTION="BYOB (Build Your Own Blocks) is an advanced offshoot of Scratch, a visual programming language primarily for kids from the Lifelong Kindergarten Group at the MIT Media Lab."
+HOMEPAGE="http://snap.berkeley.edu/old-byob.html"
+SRC_URI="http://snap.berkeley.edu/BYOB_3_1_1_110519_w_changes.zip
+http://snap.berkeley.edu/byoblib.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa oss pulseaudio nas +v4l"
+
+DEPEND="dev-lang/squeakvm[scratch] games-kids/scratch
+ alsa? ( dev-lang/squeakvm[alsa] )
+ oss? ( dev-lang/squeakvm[oss] )
+ pulseaudio? ( dev-lang/squeakvm[pulseaudio] )
+ nas? ( dev-lang/squeakvm[nas] )
+ v4l? ( dev-lang/squeakvm[v4l] )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="?? ( alsa oss pulseaudio nas )"
+
+S="${WORKDIR}/${P}.src"
+
+src_configure(){
+
+if use alsa; then squeak_sound_plugin="ALSA"
+elif use oss; then squeak_sound_plugin="OSS"
+elif use pulseaudio; then squeak_sound_plugin="pulse"
+elif use nas; then squeak_sound_plugin="nas"
+else squeak_sound_plugin="null"
+fi
+
+}
+
+src_install() {
+ local datadir="/usr/share/scratch"
+ local icondir="/usr/share/icons/hicolor"
+ dodir "${datadir}"
+ cp -r Help locale Media Projects "${D}${datadir}"
+ dodoc "BYOB 2.0.pdf" Elements090244.pdf README-BYOB.txt license.txt release.txt BYOBManual.pdf
+ dolib BYOB.image
+ dolib BYOB.changes
+ dolib BYOB.ini
+ newicon "Media/Costumes/Fantasy/alsonzo.gif" "${PN}.gif"
+
+ install_runner
+ make_desktop_entry byob BYOB byob "Education;Development" "MimeType=application/x-scratch-project"
+}
+
+install_runner() {
+ local tmpexe=$(emktemp)
+ cat << EOF > "${tmpexe}"
+#!/bin/sh
+cd
+exec \
+ "/usr/bin/squeak" \\
+-vm-sound-${squeak_sound_plugin} \\
+"/usr/$(get_libdir)/BYOB.image" \\
+"${@}"
+EOF
+ chmod go+rx "${tmpexe}"
+ newbin "${tmpexe}" "${PN}" || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-kids/byob/metadata.xml b/games-kids/byob/metadata.xml
new file mode 100644
index 0000000..273be4d
--- /dev/null
+++ b/games-kids/byob/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<longdescription lang="en">
+BYOB (Build Your Own Blocks) is an advanced offshoot of Scratch, a visual programming language primarily for kids from the Lifelong Kindergarten Group at the MIT Media Lab. This version, developed by Jens Mönig with design input and documentation from Brian Harvey, is an attempt to extend the brilliant accessibility of Scratch to somewhat older users—in particular, non-CS-major computer science students—without becoming inaccessible to its original audience. BYOB 3 adds first class lists, sprites, and procedures to BYOB's original contribution of custom blocks and recursion.
+</longdescription>
+<use>
+ <flag name="alsa">
+ Use the alsa driver plugin for sound
+ </flag>
+ <flag name="oss">
+ Use the oss driver plugin for sound
+ </flag>
+ <flag name="pulseaudio">
+ Use the pulse audio driver plugin for sound
+ </flag>
+ <flag name="nas">
+ Use the nas driver plugin for sound
+ </flag>
+ <flag name="v4l">
+ Use the camera plugin
+ </flag>
+</use>
+</pkgmetadata>