summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2017-05-25 19:26:24 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2017-05-25 19:26:24 -0400
commit12771ba8b047d831b340e5b0869e9879333ddd7b (patch)
treecc32cdbccf57199d1e1f5de28243bbb8e38015f8 /games-roguelike
parentMake it a valid ebuild (diff)
downloadsuperposition-12771ba8b047d831b340e5b0869e9879333ddd7b.tar.gz
superposition-12771ba8b047d831b340e5b0869e9879333ddd7b.tar.bz2
superposition-12771ba8b047d831b340e5b0869e9879333ddd7b.zip
NEOScavenger
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/NEOScavenger/Manifest3
-rw-r--r--games-roguelike/NEOScavenger/NEOScavenger-20160912.ebuild77
-rw-r--r--games-roguelike/NEOScavenger/metadata.xml10
3 files changed, 90 insertions, 0 deletions
diff --git a/games-roguelike/NEOScavenger/Manifest b/games-roguelike/NEOScavenger/Manifest
new file mode 100644
index 0000000..3e5b790
--- /dev/null
+++ b/games-roguelike/NEOScavenger/Manifest
@@ -0,0 +1,3 @@
+DIST NEOScavenger.tar.gz 54516473 SHA256 d90182f67899e69196fbe1aa001aa8652e01b19d7171e2b91df51964dfab41a5 SHA512 c99cc6b628632b1bdde7ea0ecd235dc0c4d608f5f70fa2e38809226dbc4048a3fd05a11a5914f004ccaefab02bf6c8e118a21854ef9937759e39f1e050129e56 WHIRLPOOL 8763a06ecf77f303dc977a735078f8c5b7ddf35345824e70ef0f811710c1e9a997966461f0545d74e872736a6055c2faaffe542566363026c32c418bfb172d40
+EBUILD NEOScavenger-20160912.ebuild 1559 SHA256 787abf97301667f706343257f6d34c0dc475405ee05622009e032d8602ef6a91 SHA512 5bd9e0290397d361431870af89c4b9f9e24cf70e3baf33f3c72abb0fdbb91cc7fbf26f20adb96b7b111fa733546520e2f2f68d43e54e785dbe65d93e5375be51 WHIRLPOOL 5df13377c60d5f938d87049e47630161df618db06717336ba160f3bf37ba48043d40e8c41f2009f89a386272074cf80bbae0e09e3017f7900c52587c1283aa80
+MISC metadata.xml 256 SHA256 c5d5792826989cac3a31ce42cfc98de139a6c499e822ea62d28e4aee41690ebb SHA512 f07a3637828d5ee8dd2fe1cf4d04d8e21107fa624017c53e0b8bd07ddab201037924a860cf83280f2666b60f6d5ab1ee56a3476e914e8fead4bcf7e7d57a5240 WHIRLPOOL ca3827eb45f17eb511311a85446916e5cb03554c418c4a6a9baf7f8cc6c89d0f7ac2b1b2e002a6d9099c839e91e39b0262dbb57f0fa73abc8391688c40bdc147
diff --git a/games-roguelike/NEOScavenger/NEOScavenger-20160912.ebuild b/games-roguelike/NEOScavenger/NEOScavenger-20160912.ebuild
new file mode 100644
index 0000000..a86e532
--- /dev/null
+++ b/games-roguelike/NEOScavenger/NEOScavenger-20160912.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="survive in the wasteland long enough to figure out who you are"
+HOMEPAGE="http://bluebottlegames.com/main/node/2"
+SRC_URI="NEOScavenger.tar.gz"
+
+LICENSE="AdobeFlash-11.x"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="fetch mirror"
+IUSE="+multilib"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ multilib? (
+ dev-libs/atk[abi_x86_32]
+ dev-libs/glib:2[abi_x86_32]
+ dev-libs/nspr[abi_x86_32]
+ dev-libs/nss[abi_x86_32]
+ media-libs/fontconfig:1.0[abi_x86_32]
+ media-libs/freetype:2[abi_x86_32]
+ x11-libs/cairo[abi_x86_32]
+ x11-libs/gdk-pixbuf:2[abi_x86_32]
+ x11-libs/gtk+:2[abi_x86_32]
+ x11-libs/libX11[abi_x86_32]
+ x11-libs/libXcursor[abi_x86_32]
+ x11-libs/libXext[abi_x86_32]
+ x11-libs/libXrender[abi_x86_32]
+ x11-libs/libXt[abi_x86_32]
+ x11-libs/pango[abi_x86_32]
+ )
+ !multilib? (
+ dev-libs/atk
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/pango
+ )"
+
+S="${WORKDIR}/${PN}"
+
+REQUIRED_USE="amd64? ( multilib )"
+
+pkg_nofetch() {
+ ewarn
+ ewarn "Place ${A} to ${DISTDIR}"
+ ewarn
+}
+
+src_install() {
+ local dir ="/opt/${PN}"
+ dodir "${dir}"
+ into "${dir}"
+
+ doexe "${PN}"
+ dodoc _readme.txt
+ doins -r *
+
+ newicon img/x2_nsLogo.png "${PN}.png"
+ make_desktop_entry "${PN}" "${DESCRIPTION}" "${PN}"
+
+}
diff --git a/games-roguelike/NEOScavenger/metadata.xml b/games-roguelike/NEOScavenger/metadata.xml
new file mode 100644
index 0000000..6b7f351
--- /dev/null
+++ b/games-roguelike/NEOScavenger/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>phil_miess@mail.yahoo.com</email>
+</maintainer>
+<longdescription lang="en">
+NEO Scavenger (playable as a stand-alone download or in the browser via Flash) is a game where you must survive in the wasteland long enough to figure out who you are. Each turn you must decide where to go, how to scavenge for supplies, and how to deal with anything and anyone you encounter. And with each passing minute, the pit in your stomach grows, your dehydration worsens, your muscles tire, and your body temperature drops in the cold autumn air. Choose your starting abilities carefully, because they and your wit are the only tools you have in the apocalypse!
+</longdescription>
+</pkgmetadata>