summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2020-04-11 22:33:30 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2020-04-11 22:33:30 -0400
commit3836cdd2f7b11e9dfb4ea54777621b4820b96c48 (patch)
tree80369ae9911a142d309d0dcb558ebfea35fcea70 /sys-apps
parentfix has version atom (diff)
downloadsuperposition-3836cdd2f7b11e9dfb4ea54777621b4820b96c48.tar.gz
superposition-3836cdd2f7b11e9dfb4ea54777621b4820b96c48.tar.bz2
superposition-3836cdd2f7b11e9dfb4ea54777621b4820b96c48.zip
patch async import error
Signed-off-by: Philip Miess <Philip_Miess@yahoo.com>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/0install/0install-2.3.7.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/sys-apps/0install/0install-2.3.7.ebuild b/sys-apps/0install/0install-2.3.7.ebuild
index 0155ffe..4b84f5f 100644
--- a/sys-apps/0install/0install-2.3.7.ebuild
+++ b/sys-apps/0install/0install-2.3.7.ebuild
@@ -26,6 +26,7 @@ python_check_deps() {
python_prepare_all() {
# Change manpage install path (Bug 207495)
sed -i 's:man/man1:share/man/man1:' setup.py || die 'Documentation path fix sed failed.'
+ sed -i 's:from async_compat import:from zeroinstall.support.async_compat import:' zeroinstall/support/tasks.py || die 'async import sed failed.'
distutils-r1_python_prepare_all
}