aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/gtk-fortran/gtk-fortran-3.9999-r1.ebuild')
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-3.9999-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-libs/gtk-fortran/gtk-fortran-3.9999-r1.ebuild b/x11-libs/gtk-fortran/gtk-fortran-3.9999-r1.ebuild
new file mode 100644
index 0000000..5b989bf
--- /dev/null
+++ b/x11-libs/gtk-fortran/gtk-fortran-3.9999-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils fortran-2 git-2
+
+DESCRIPTION="Cross-platform Fortran binding to create GUIs using GTK+"
+HOMEPAGE="https://github.com/jerryd/gtk-fortran/wiki"
+
+LICENSE="GPL-3"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+
+EGIT_REPO_URI="https://github.com/jerryd/gtk-fortran.git"
+EGIT_BRANCH="gtk3"
+
+DEPEND="x11-libs/gtk+:3 x11-libs/cairo x11-libs/gdk-pixbuf"
+RDEPEND="${DEPEND}"
+
+# Cannot do a parallel build:
+src_compile() {
+ cd "${CMAKE_BUILD_DIR}"
+ emake -j1 VERBOSE=1 || die
+}